nat63nesnova5
?>

Составить программу в паскале: вывести все простые числа в диапазоне от 1 до n, используя циклические конструкции.

Информатика

Ответы

Александрович686

program n1; uses crt; var n,i,k,j: integer; beginclrscr; writeln('vvedite n'); readln(n); writeln('prostye chisla'); writeln; for i: =3 to n dobegin for j: =2 to i-1 do if i mod j=0 then k: =k+1; if k=0 then writeln(i); k: =0; end; readlnend.

zakaz6354
#4 a) 1 2 3 4 5 b) 1 1 2 4 3 9 4 16 5 25 6 36 7 49 8 64 9 81 10 100 c) пустой вывод #5 n = 5 #6 until n > 10 or a == 0 #7 a) program _1to10; var i: integer; begin for i : = 1 to 10 do write(i, ' ') end. b) program sqr_7_27; var i: integer; begin for i : = 7 to 27 do   begin       if i mod 2 == 1 then           write(sqr(i), ' ');   end; end. c) program sqrt_3_4per_23; var i: integer; begin   i : = 3;   repeat       write(sqrt(i), ' ');       i : = i + 4;   until (i > 23); end.
Shirochkingames
Подозреваю, что не самый рациональный метод решения, но чем смог тем : ) const  n = 30;   var  a: array [1..n] of longint;   i, j, k: longint;   begin  for i : = 1 to n do  readln(a[i]);   j: =0;   k: =0;   for i: =1 to n do begin  if (abs(a[i])> =10) and (abs(a[i])< 100) and (a[i]> 0) then inc(k);   if (abs(a[i])> =10) and (abs(a[i])< 100) and (a[i]< 0) then inc(j);   end;   if k> j then writeln(j)  else if k< j then writeln(k)  else if k=j then writeln(k);   end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в паскале: вывести все простые числа в диапазоне от 1 до n, используя циклические конструкции.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alekseymedvedev1981
Aleksandr362
annayarikova
Джулия
Vrpeshka
llmell6
Надья-Олеговна
Babushkina27
zolotayaoxana1982
ВасилийМалюга152
yuliasam
linda3930
uuks2012
luxoutlet
Sadovskaya425