vnolenev
?>

Решите по программированию как мы знаем шоколадки дарят только тем, кто хорошо прошел iq тест. поэтому в детском саду №603075 решили подарить 228 грамм шоколада каждому ребенку, кто набрал не менее x за тест. шоколад продаётся плитками по 1337 грамм. плитка ломается на кусочки по 228 грамм и эти кусочки детям. остаток не выбрасывается и учитывается в следующем подарке. определите сколько детей получат награду и сколько плиток шоколада для этого необходимо приобрести. формат ввода в первой строке вводится n, x (1 < = n < = 105, 1 < = x < = 109) — количество детей и необходимый минимальный результат теста. в следующей строке вводится n целых положительных чисел не превышающих 109 — результаты теста. формат вывода выведите два числа — количество заслуженных обладателей кусочков шоколада и количество необходимых плиток шоколада.

Информатика

Ответы

ivanrancev

program raf105;

var iq,n,x,i,choco,choco_counter,kid_counter: integer;

begin

write('введите количество детей в детском саду: ');

readln(n);

write('введите желаемый iq: ');

readln(x);

writeln('вводите iq ',n,' детей по очереди.');

for i: =1 to n do

begin

  readln(iq);

  if iq > = x

    then begin

      if choco div 228 < 1

        then begin

          choco_counter+= 1;

          choco+= 1337;

        end;

      choco-= 228;

      kid_counter+= 1;

    end;

end;

writeln('награду получат ',kid_counter,' дет.');

writeln('шоколада потребуется приобрести: ',choco_counter,' плит.');

end.

pascalabc 3.4.2
Лилит_Шутова

нц пока не сверху свободно

закрасить

вправо

кц

 

нц пока сверху свободно

вправо

кц

 

нц пока справа свободно

закрасить

вправо

кц

 

нц пока не справа свободно

закрасить

вниз

кц

 

нц пока справа свободно

вниз

кц

 

нц пока не справа свободно

закрасить

вниз

кц

 

 

15.2 Решение

 

var k, n, a, amax: integer;

begin

amax:=0;

readln(n);

for k:=1 to n do

begin

readln(a);

if (a mod 5 = 0) and (a>amax) then

amax:=a;

end;

writeln(amax);

end.

 

Для проверки правильности работы программы необходимо использовать следующие тесты:

 

Объяснение:

dg9792794674

1 Для удобство содержания

2 Гиперссылка— часть гипертекстового документа, ссылающаяся на элемент в этом документе

3-4 Чтобы сделать гиперссылку на страницу или файл в интернете, выделяете текст или картинку, которые потом станут кликабельны, и в верхнем меню выбираете последовательно Вставка - Ссылки - Гиперссылка (или нажимаете на выделенный текст или картинку правой кнопкой мыши, и в выпадающем меню выбираете пункт Гиперссылка).

Далее в окошке "Вставка гиперссылки" заполняете поля:

"Связать с" - выбираете Файл, Веб-страница

"Адрес" - вставляете ссылку на страницу или файл.

Нажимаете ОК и готово!

5 Итак, чтобы сделать оглавление в ворде автоматически, нужно сначала разбить документ на разделы с заголовками, а потом перейти во вкладку "Главная" - "Стили". К названиям разделов, которые требуется внести в содержание, примените соответствующие стили. Например, для названий разделов можно применить «Заголовок 1», а для подразделов «Заголовок 2».

6 А́вторское пра́во — институт гражданского права, регулирующий правоотношения, связанные с созданием и использованием

7 Плагиа́т — умышленно совершаемое физическим лицом незаконное использование или распоряжение охраняемыми результатами чужого творческого труда

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите по программированию как мы знаем шоколадки дарят только тем, кто хорошо прошел iq тест. поэтому в детском саду №603075 решили подарить 228 грамм шоколада каждому ребенку, кто набрал не менее x за тест. шоколад продаётся плитками по 1337 грамм. плитка ломается на кусочки по 228 грамм и эти кусочки детям. остаток не выбрасывается и учитывается в следующем подарке. определите сколько детей получат награду и сколько плиток шоколада для этого необходимо приобрести. формат ввода в первой строке вводится n, x (1 < = n < = 105, 1 < = x < = 109) — количество детей и необходимый минимальный результат теста. в следующей строке вводится n целых положительных чисел не превышающих 109 — результаты теста. формат вывода выведите два числа — количество заслуженных обладателей кусочков шоколада и количество необходимых плиток шоколада.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

perfectorg
Сухроб944
missmorozova2
tvtanya80
Рузиев_Давиденко
mustaevdmitry397
ibird777
ShALIGINA
anastasiaevent4
Shtorm-Shoe
ПетросовичЗаславский
Назначение всех клавиш клавиатуры (, )
Алексеевна
zorinka777
metegina4
emaykova785