mirdetzhuk79
?>

Нужно написать программу которая определяет является ли сумма цифр двухзначного числа четной

Информатика

Ответы

Оксана Николаевич

если число не длинное, то можно считать в стринг. но если число длинное, то это не прокатит

 

var

q: string;

i,a,n: integer;

 

begin

readln(q):

n: =length(q);

for i: =1 to n do

a: =strtoint(q[i]);

if a mod 2 = 0 then writeln("yes) else writeln("no");

 

end.

sergey

массовость. алгоритмы сложения, вычитания, умножения и деления могут быть применены для любых чисел, причем не только в десятичной, но и в других позиционных системах счисления (двоичной, восьмеричной, шестнадцатеричной и возможность применения алгоритма к большому количеству различных исходных данных называется массовостью.

само слово "алгоритм" происходит от "algorithmi" - латинской формы написания имени ix века аль-хорезми, который сформулировал правила выполнения арифметических операций.

детерминированность. при самолетом используются сложные алгоритмы, исполнителями которых являются пилот или бортовой компьютер. последовательность выполнения действий, например, при взлете должна быть строго определенной (например, нельзя отрываться от взлетной полосы, пока самолет не набрал необходимую взлетную скорость). исполнитель алгоритма, выполнив очередную команду, должен точно знать, какую команду необходимо исполнять следующей. это свойство алгоритма называется детерминированностью.

nkochladze

1.  меньше тигра, больше кошки,над ушами кисти-рожки,с  виду  — кролик, но  не  верь -страшен в  гневе этот зверь! и  ему не  крикнешь «брысь»! потому что это   (рысь)

2.  он  слетает белой стаейи  сверкает на  лету,он  звездой прохладной таетна  ладони и  во    (снег)

3.  кто осенью спать ложится,а  весной   (медведь)

4.  жил я  посреди двора,где играет детвора.но  от  солнечных лучейпревратился я  в    (снеговик)

5.  что вверх корнем растёт?   (сосулька)

6.  из  капкана он  уйдёт,из  аркана убежит,в  тундре звёздной и  морознойвсюду путь ему   (ветер)

7.  за  белой дверцей стужа, лёд.там дед мороз, друзья, живёт.  (холодильник)

8.  пришла из  лесу птичница в  рыжей шубке кур посчитать.  (лисичка)

9.  белой стайкой мошкаравьётся, кружится с  утра.не  пищат и  не  кусают,просто так себе летают.  (снежинки)

10.  скачет по  лесу то  взад, то  вперёд,воет, гудит, деревья трясёт.  (вьюга)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу которая определяет является ли сумма цифр двухзначного числа четной
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Беспалова
Valentina1520
svetkaiv
sadkofamily61
Владимир1524
zverevahelen
julichca68
Анатольевич1707
Юлия-Ольга1313
Vgubushkin
yanermarina87
Баранов955
centrprof20
Буянто1346
iivanovar-da