Gennadievna bessonov
?>

Составьте программу на языке паскаль которая уменьшает первое число в 5 раз если оно больше второго по абсолютной величине.

Информатика

Ответы

molchanovaelena284

var

  a, b: real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  if abs(a) > b then

      a : = a / 5;

  writeln;

  writeln('a = ', a);

  writeln('b = ', b);

  writeln;

end.

 

Olesya-elena1525

var

  a, b : real;

begin

  read (a, b);

  if abs (a) > abs (b) then a : = a / 5;

  writeln (a, ' ', b);

end.

yusinelnik8
Добрый день. могу предложить следующий вариант решения данного : 1) 100 в 5 cc и 200 в 4 сс переводим в 10 сс.  получаем: ^ - возведение в степень. 100(5)=5^0*0+5^1*0+5^2*1=25(10); 200(4)=4^0*0+4^1*0+4^2*2=32(10). 2) решаем элементарное уравнение в 10 сс: 25+x=32; x=32-25;   x=7(10). обращаем внимание, что ответ мы получили в десятичной системе счисления! 3) переводим полученный ответ в семеричную систему счисления: 7(10)=10(7). используем метод деления числа в исходной сс на основание новой сс. 
Vyacheslav_Nikolaevna

list_ask=[["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"],

["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"]]

for i in list_ask:

  answer=input(i[0])

  if answer==i[1]:

      print("твет верный")

  else:

    print("ответ не верный")

ps random:

import random as r

list_ask=[["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"],

["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"]]

for i in range(len(list_ask)):

  n=r.randint(0,len(list_ask))

  x=input(list_ask[n][0])

  if x==list_ask[n][1]:

    print("ответ верный")

  else:

    print("ответ не верный")

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке паскаль которая уменьшает первое число в 5 раз если оно больше второго по абсолютной величине.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Gera8061
ganorussia
Akvamontaz
suturinavaleriya51
opal19575
cleopatra1959
Seropyan-Elena1944
Kuznetsova1639
afilippov3321
stmr29
Vitalevich1187
xsmall1
SERGEI124
vasilyevjob6
Назаров588