zaha98
?>

1.ипполит задумал трёхзначное число, которое при делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. напишите программу, которая находит все такие числа. в паскале. 2.с клавиатуры вводится натуральное число n. программа должна найти факториал этого числа (обозначается как n! ) – произведение всех натуральных чисел от 1 до n. например, 5! = 1 • 2 • 3 • 4 • 5 = 120.3.натуральное число называется числом армстронга, если сумма цифр числа, возведенных в n-ную степень (где n – количество цифр в числе) равна самому числу. например, 153 = 1^3 + 5^3 + 3^3.найдите все трёхзначные армстронга. реши без ошибок. ​

Информатика

Ответы

marinakovyakhova

1)

var   i: integer;

begin

for i : = 100 to 999 do

if (i mod 15 = 11) and (i mod 11 = 9)

then writeln(i);

end.

2)

var   i,n,s: integer;

begin

read (n);

s : = 1;

for i : = 1 to n do

s : = s * i;

write(s);

end.

3)

var i,j,k: integer;

begin

for i: =1 to 9 do

for j: =0 to 9 do

for k: =0 to 9 do

if i*i*i+j*j*j+k*k*k=i*100+j*10+k

then writeln(i*100+j*10+k);

end.

ГармаеваЕкатерина1637
реализация на python --

import datetime

import time

from math import sqrt

 

utc = datetime.datetime.utcnow

 

class myclass:

      def , number):

            self.number = number

            self.res = 0

            self.acc = [[1]]

 

      def addtopos(self, pos, i):

              self.acc[pos] = self.acc[pos] + [i]

 

      def addtotail(self, i):

              self.acc = self.acc + [[i]]

 

      def testpos(self, pos, i):

              ret = true

              for x in self.acc[pos]:

                      if i % x == 0:

                              ret = false

                              break

              return ret

 

      def addcand(self, i):

              ret = false

              pos = 0

              for lst in self.acc:

                  if self.testpos(pos, i):

                      ret = true

                      self.addtopos(pos, i)

                      break

                  pos = pos + 1

 

              if not ret:

                      self.addtotail(i)

 

 

      def calc(self):

              for i in range(2, self.number + 1):

                      self.addcand(i)

              print(self.acc)

              print(len(self.acc))

 

def test(num):

    start = utc()

   

    cl = myclass(num)

    cl.calc()

 

    print (utc() - start)

 

if __name__ == '__main__':

      test(int(

     

    python test.py 9 [[1], [2, 3, 5, 7], [4, 6, 9], [8]] 4
Дмитрий-Олейникова
#код на ruby 2.2.3p173 a = [] a < < [1] for i in 2..10001       f = 0       a.each{ |group|             m = 1             group.each { |c|                   m *= i % c             }             f += m             if m > 0                   group < < i                   break             end       }       a < < [i] if f == 0 end p a p a.size

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.ипполит задумал трёхзначное число, которое при делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. напишите программу, которая находит все такие числа. в паскале. 2.с клавиатуры вводится натуральное число n. программа должна найти факториал этого числа (обозначается как n! ) – произведение всех натуральных чисел от 1 до n. например, 5! = 1 • 2 • 3 • 4 • 5 = 120.3.натуральное число называется числом армстронга, если сумма цифр числа, возведенных в n-ную степень (где n – количество цифр в числе) равна самому числу. например, 153 = 1^3 + 5^3 + 3^3.найдите все трёхзначные армстронга. реши без ошибок. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gallush9
Reginahappy
Матфеопуло1006
ver2bit
vera4
vickuznetsova8677
iskypka
elenak26038778
Рузиев_Давиденко
Amulenkov
Каныбек698
zerckaln
smileystyle
olimov9
okutihamv