Елена-Семенова
?>

Написать программу, которая будет складывать 2 числа и делить эту сумму на 20. кто понимает, объясните !

Информатика

Ответы

Arzieva Abdulmanov1438

input a,b

c=(a+b)/20

? c

edvard-b

program z1;

var a,b,s: integer;

begin

writeln ('vvedite a'); readln (a);

writeln ('vvedite b'); readln (b);

s: =(a+b)/20;

writeln ('otvet',s');

end.

alenchik19938823

ответ:

основным отличием вычислительной машины от таких счетных устройств, как счеты, арифмометр, калькулятор, заключается в том, что вся последовательность команд на вычисление предварительно записывается в память вычислительной машины и выполняется последовательно автоматически.   машина состояла из памяти, арифметико-логического устройства (алу), устройства ввода-вывода и устройства

1) устройство ввода передавало команды и данные в алу, откуда они записывались в память.

2) все команды, совокупность которых называется программой, записываются в память в соседние ячейки по возрастанию их адресов, а данные, которые требуют обработки,— в ячейки с произвольными адресами.

3) последняя команда программы – это обязательно команда остановки работы. каждая команда содержит код операции, которую необходимо выполнить, и адреса ячеек, в которых находятся данные, обрабатываемые этой командой. устройство содержит специальный регистр, который называется «счетчик команд». после загрузки программы и данных в память в счетчик команд записывается адрес первой команды программы. после чего вычислительная машина переходи, в режим автоматического выполнения программы.

4) устройство считывает из памяти содержимое ячейки памяти, адрес которой находится в счетчике команд, и помещает его в специальное устройство – «регистр команд». регистр команд хранит команду во время ее исполнения.

5) устройство расшифровывает тип операции команды, считывает из памяти данные, адреса которых указаны в команде, и приступает к ее выполнению. для каждой команды устройство имеет свой алгоритм обработки, который заключается в выработке сигналов для всех остальных устройств машины.

6) устройство читает команду, адрес которой находится в счетчике команд, помещает ее в регистр команд . этот процесс продолжается до тех пор, пока очередная исполняемая команда не оказывается командой останова исполнения программы.

7)   особым случаем можно считать команды безусловного или условного перехода. в этом случае команда перехода содержит адрес ячейки, куда требуется передать . этот адрес записывается устройством непосредственно в счетчик команд и происходит переход на соответствующую команду программы.

вот и все. если что- то надо пиши. объясню.

Vello Olga

ответ:

брат такой ответ дал незнаю нащет правельно с и но может правельно)

c++выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

#include

#include

#include

#include

#include

using namespace std;

void main()

{

setlocale(0, "");

srand(time(null));

int a[10] = {};

int b[5] = {};

int c[5] = {};

for (int i = 0, q = 0; i < 10; i++)

{

a[i] = rand() % (20 - (-20) + 1) + (-20);

cout < < a[i] < < endl;

if (a[i] % 2 == 0)

{

cout < < "" < < endl;

b[q] = a[i];

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая будет складывать 2 числа и делить эту сумму на 20. кто понимает, объясните !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

МихайловнаLarisa1150
testovich1012
sawa-msk
natachi
picassovrn
Казаков
Tamara
Adassa00441
gorbelena1971
irinanikulshina144
Борисовна_Кашутина
Semenovt
Pavlovna-Golovitinskaya378
klykovav672
vasilevam