det-skazka55
?>

Составьте программу замены в слове, введенном с клавиатуры, всех букв"и" на"а"и"а"на"о".сосчитать количество замен.отладка программы для слова"накидка"

Информатика

Ответы

Михаил736

program stroka;

uses crt;

var a: string;

 

      c1,c2, i,k: integer;  

begin

    clrscr;

    write('введите строку: ');

    readln(a);

    k: =length(a);

c1: =0; c2: =0;

 

// первый проход меняем "и" на  "a"  

    for i: =1 to k do    if(a[i]='и') or (a[i]='и') then

        begin  

                a[i]: ='а';

                c1: =c1+1;

 

          end;

    // второй проход меняем "а" на  "о"      

 

    for i: =1 to k do    if(a[i]='а') or (a[i]='а') then

            begin

 

                  a[i]: ='о';      

                  c2: =c2+1;    

 

              end;

writeln;

 

 

 

  writeln('строка после всех замен: ',a);

 

  writeln('замен и на а: ',c1);

  writeln('замен a на о: ',c2);  

    readkey;

 

end. 

 

 

Svetlana290419
500 байт = 4000 бит, т.к в одном байте 8 битов(значит умножаем 500 на 8, получаем 4000).  5 кб =  5120 байт, т.к в 1 кб 1024 байтов, значит умножаем 5 на 1024, получаем 5120 87 гб =  93415538688 байт, т.к в 1 гб 1024 мб, в 1 мб 1024 кб,в 1 кб 1024 байт. получаем 1024*1024*1024(1024 в кубе) = 1073741824 байт в 1 гб. умножаем 87 на 1073741824 = 93415538688  байт 7 мб = 58720256 бит, т.к в 1 мб 1024 кб, в одном кб 1024 байт, в одном байте 8 бит. значит 1024*1024*8=8388608 бит в одном мб. 7*8388608=58720256 бит в 7 мб 46 байт =  0,000044 мб. байт - 0,0009765625 часть кб(1 разделить на 1024, т.к в одном кб 1024 байт). опять-таки делим получившееся число(0, на 1024, получаем 0,00000095367431640625.  теперь мы знаем, что 1 кб - 0,00000095367431640625 часть мб, умножаем 0,00000095367431640625 на 46, получаем 0,0000438690185546875, можно, думаю, округлить. получим как раз-таки, округлив, 0,000044. 700000 бит = 85,45 кб. получили это число, разделив 700000 на 8(в 1 байте 8 бит). получаем 87500 байтов. в 1 кб 1024 байтов. делим 87500 на 1024, получаем 85,44921875 кб в 700000 битах. округлив, получаем 85,45 кб. 
fedchenkoofficial
Ябы купила macbook air 13 2016 модельного года, так как это идеальный компьютер для работы и учебы. я бы взяла с 8 гб оперативной памяти и 512 гб   ssd для быстрой работы. у него достаточно мощный процессор intel core i5. его полностью хватает на повседневные и даже в 3d редакторах. аккумулятор   способен держать ноутбук в тонусе на протяжении 12 часов без подключения к сети. идеал для студента или школьника! ноутбук обладает самым лучшим тачпадом с поддержкой жестов! полноразмерная клавиатура обладает регулируемой подсветкой!   и главной отличительной чертой всех продуктов apple является - по!   множество качественно программного обеспечения и отсутствие вирусов - непаханое поле для работы!   все это подчеркивает строгий, легкий, компактный корпус. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу замены в слове, введенном с клавиатуры, всех букв"и" на"а"и"а"на"о".сосчитать количество замен.отладка программы для слова"накидка"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

jnrhjq3597
elenachuxina804
heodbxbbshe
Anna Artem
спец387
bogdanyukn562
ddavydov1116
yok887062
Kulikovvl9
laleonaretouch
kiparistop
ИП-Сысоев1628
Ермакова Ирина674
Misyura_Viktoriya1683
Roman913
▲