Написать программу вычисления стоимости покупки с учетом скидки. скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% — если сумма больше 1000 руб. (pascal)
Var s: real; begin write('введите сумму покупки: '); readln(s); if s > 1000 then s : = s * (1 - 0.05) else if s > 500 then s : = s * (1 - 0.03); writeln('сумма покупки с учетом скидки: ', s); end.
orantus3
02.04.2020
1 var k,i,n,c: integer; 2 p,w: real; 3 begin4 repeat5 write('k> -3 k=') ; 6 readln(k) ; 7 until k> -3 ; 8 w: =0; 9 c: =1; 10 for i: =-3 to k do 11 begin 12 c: =-c; {-1^i} 13 p: =1; 14 for n: =i to 2*k do15 if n< > 2 then p: =p*(n*n*n-8) ; 16 if i< > 5 then w: =w+(c/sqr(i-5))* p; 17 end; 18 write('w=',w: 0: 4) 19 end .это?
Araevich
02.04.2020
{как найти количество и сумму всех четных чисел, положительных чисел числового ряда 2,4,3,0,2,5,-2,5}const a: array[1..8] of integer=(2,4,3,0,2,5,-2,5); var i,q,r,n,m: integer; beginwrite('числовой ряд '); for i: =1 to 8 do beginwrite(a[i]: 4); if a[i] > 0 then m: = m + 1; if (a[i] mod 2)= 0 then n: = n + 1; if ((a[i] mod 2)= 0)and (a[i] > 0) then r: = r + 1; end; writeln; writeln('четных чисел ', n); writeln('положительных чисел ', m); writeln('положительных и четных чисел ',r); end.