kayrina
?>

Составить программу на языке паскаль абс.дано радиусы двух окружностей. найти площадь кольца.

Информатика

Ответы

ganul

sasha12341234 издеваешься? знать с++ и не написать на паскале? ? ну если дано r и rvar r,r1: integer; s,pi: real; beginpi: =3.14; r: =15; //bigr1: =10; //smalls: =pi*(r-r1); writeln(s); readlnend.

peregovorkacoffee
Простите-си++ и си только знаю.
КириллЕгорова1906

паровозы кажется могут толкать состав назад, ехать как задом так и передом и тп. иначе я не знаю.

 

первый поезд делится на (паровоз+10) и 11 вагонов.

и эту десятку паровоз тянет в тупичек.

второй поезд проезжает тупичек.

паровоз первого вытягивает свою десятку на свободный путь

второй паровоз толкает свой состав так чтоб стать перед тупичком

второй паровоз отцепляется и прицепляется к оставшимся 11 вагонам.

второй паровоз задом запихивает 11 вагонов в тупичек

второй паровоз берет свой состав и уезжает

первый паровоз забирает свои 11 вагонов

impulsmc715

var s: string;

i,j,k: integer;

unique: boolean;

begin

  for i : = 1000 to 9999 do

  begin

        s : = str(i);

        unique: =true;

        for j: = 1 to length(s)-1 do

              for k : = j+1 to length(s) do

              begin

                    if s[j] = s[k] then unique: =false;

              end;

        if unique then

            writeln(i);

  end;

end.

 

может длинее, но универсальное.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке паскаль абс.дано радиусы двух окружностей. найти площадь кольца.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zapros
Мария1414
Viktorovna_Yurevna
zolotayaoxana1982
irinanikulshina144
adminaa
Екатерина
yurogov61
aci2003
mvolkov8
Belik-elena20111
olechka197835
Sknyajina5
eobmankina