Создайте следующую игру: главный персонаж - байкер, движение которого осуществляется с клавиатуры (wasd), должен собрать все звездочки на поляне.в ответе укажите программу для байкера. cрочно
Program area; var a,b,c,p,s: real; i,n: integer; begin writeln('введите число треугольников: ' ); readln(n); i : = 1; while i < = n do begin write('введите сторону a треугольника #' , i , ': '); readln(a); write('введите сторону b треугольника #' , i , ': '); readln(b); write('введите сторону c треугольника #' , i , ': '); readln(c); p : = (a+b+c)/2; s : = sqrt(p*(p-a)*(p-b)*(p-c)); writeln('s_',n, ' = ',s); i : = i+1 end; end.
znaberd786
13.07.2021
От числа 1000000, указанного в программе, будет зависеть скорость движения. можешь изменить его, если прямоугольник двигается быстро или наоборот, медленно screen 12 x = 150 for i = 0 to 460 line (x, + 10, y + 20), 0, b y1 = i line (x, + 10, y1 + 20), , b y = y1 for n = 1 to 1000000 next n next i for i = 460 to 0 step -1 line (x, + 10, y + 20), 0, b y1 = i line (x, + 10, y1 + 20), , b y = y1 for n = 1 to 1000000 next n next i