б
интересно, что никто и никогда не видел белого слона! белыми иногда называют светлых слонов, в древности считавшихся священными. в некоторых частях света им даже поклонялись.+
белые слоны считались настолько ценными, что лишь королю было позволительно владеть таким слоном! и это было весьма кстати: окруженные величайшей заботой, белые слоны пользовались всеми дорогостоящими атрибутами роскоши. они никогда не работали и жили в отдельных помещениях. у них были свои слуги, специально приставленные заботиться о белых слонах, а еда им подавалась зачастую в серебряных кормушках людьми в белых одеждах.
а насчет а я сейчас подумаю
а потом отправлю через комментрии
Поделитесь своими знаниями, ответьте на вопрос:
Эллементы массива вычисляются по формуле a(x, y)=2x^2-y^2 написать программу, которая выводит на экран значения элементов массива а(2, 2 подсчитать количество отрицательных элементов сумму положительных элементов выводит на экран номера всех элементов, значения которых =0
проверено - работает на паскаль авс.
кстати, похоже на какую-то ошибку в условии : по формуле a(x,y)=2x^2-y^2 ни один элемент массива никогда не будет равен 0.
program lobu; uses crt; const n=2; var a: array[1..n,1..n] of real; neg,sum: real; i,j: integer; begin writeln('*** alphaues is ***'); writeln('*** ok ***'); neg: =0; sum: =0; for i: =1 to n do begin for j: =1 to n do begin a[i,j]: =2*i*i-j*j; write (a[i,j]: 7: 2); if a[i,j]< 0 then neg: =neg+1; if a[i,j]> 0 then sum: =sum+a[i,j]; if a[i,j]=0 then writeln('элемент а(',i,',',j,') равен 0'); end; writeln(); end; writeln(); writeln('количество отрицательных чисел ',neg); writeln('сумма положительных чисел ',sum); end.