ftyh6
?>

Составьте программу, которая во введенной с клавиатуры строке определит наименьшую длину слова. считать что слова всегда разделены пробелами. пример: вася любит молоко ответ: 4

Информатика

Ответы

puma802
На каком языке программа-то
dmitrovlug8248
Последнее проверяемое число 7ff, поскольку большее число при удвоении будет четырехзначным, нарушая условие . procedure analyze(n: integer; var sd: integer; var has2: boolean); {для заданного целого n возвращает:   sd - сумму цифр в шестнадцатиричном представлении;   has2 - true, если среди шестнадцитиричных цифр имеется хотя бы одна двойка.} const   mask = $00f; var   i, r: integer; begin   has2 : = false;   sd : = 0;   for i : = 1 to 3 do   begin       r : = (n and mask);       has2 : = (has2 or (r = 2));       sd : = sd + r;       n : = (n shr 4);   end end; function issuitable(n: integer): boolean; {проверяет, удовлетворяет ли число n набору условий} var   s1, s2: integer;   has2, stub: boolean; begin   analyze(n, s1, has2);   analyze(2 * n, s2, stub);   issuitable : = ((s1 = s2) and has2) end; var   i, n: integer; begin   n : = 0;   for i : = $100 to $7ff do       if issuitable(i) then n : = n + 1;   writeln('найдено чисел- ', n) end. результат выполнения программы: найдено чисел- 23
Nataliya Aleksandr1197

program test;

var i: integer;

begin

for i:=11 to 99 do

if i=(i+i-1) div 10 + (i+i-1) mod 10 * 10 then

writeln (i-1,' ',i)

end.

36 и 37

Объяснение:

for i:=11 to 99 do - перебираем двузначные числа

(i+i-1) - вычисляем сумму двух последовательных двузначных чисел

(i+i-1) div 10 - получаем первую цифру получившейся суммы

(i+i-1) mod 10 - получаем вторую цифру получившейся суммы

(i+i-1) mod 10 * 10 - чтобы переставить цифры в сумме умножаем последнюю цифру на 10 (из единиц делаем десятки)

(i+i-1) div 10 + (i+i-1) mod 10 * 10 - переставляем цифры в получившейся сумме

if i=(i+i-1) div 10 + (i+i-1) mod 10 * 10 then - сравниваем большее из двузначных чисел с числом получившемся после перестановки цифр суммы


Создайте программу на Pascal ABC! Два последовательных двузначных числа сложили и в их сумме переста
Создайте программу на Pascal ABC! Два последовательных двузначных числа сложили и в их сумме переста

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая во введенной с клавиатуры строке определит наименьшую длину слова. считать что слова всегда разделены пробелами. пример: вася любит молоко ответ: 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

demakova1969
guujuu
Fetyukov
stendpost
orgot9
oduvanalex
predatorfishing608
dimiff5
Мусаев Игоревич371
savva-vika
sport2293032
TatianaSeliverstova64
elizabetmaslova3
Zhanna417
IP1379
▲