okabankova7
?>

Составить программу. -сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен квадрату текущего индекса, увеличенному на 5; 2-й равен целой части квадратного корня из предыдущего элемента; 3-й равен целой части от деления двух предыдущих элементов.

Информатика

Ответы

format-l3364
Var   i : integer;   aa : array[1..9] of integer; begin   { высчитываем элементы массива  }   for i : = 1 to 9 do     if i mod 3 = 1 then       aa[i] : = (i + 5) * (i + 5)     else if i mod 3 = 2 then       aa[i] : = round(sqrt(aa[i-1]))     else       aa[i] : = aa[i-1] div aa[i-2];   { выводим значения на экран  }   for i : = 1 to 9 do     write(aa[i], ' '); end.
Ioanova Korneeva1093
Сразу же очевидно, что лена - не дочь а.и. (1) 1. пусть анна - дочь а.и.(1), тогда тома должна была танцевать с ним, но этого не может быть, так как а.и. танцевал с леной. значит, анна - не дочь а.и. 2. пусть катя - дочь а.и.(1), тогда анна танцевала с а.и.(1), но этого также не может быть, так как он танцевал с леной. катя - не дочь а.и. значит, остаётся только один вариант - тома дочь а.и.(1). следовательно, в.с.(3) танцевал с томой. 4. пусть катя - дочь в.с.(3), тогда с ним танцевала анна, но этого не может быть, так как с ним танцевала тома. 5. пусть лена - дочь в.с.(3), но тогда с ней должен был танцевать ф.п., а это невозможно, так как с леной танцевал а.и.(1). следовательно, анна - дочь в.с.(3). осталось разобраться с ф.п. и  г.а. 6. ф.п.(2) - танцевал с дочерью в.с., значит от танцевал с анной, т.е. он - отец кати. 7. соответственно г.а. - отец лены и танцевал с катей. пары отец-дочь: 1т 2к 3а 4л
Artak96993298
Var i, k, j: byte;       begin     k: =0;     for i: =1 to 20 do           begin           for j: =1 to 20 do           begin           write(i*j: 4);           if i*j mod 2< > 0 then inc(k);           end;           writeln;           end;     writeln('количество нечетных чисел=', k);   end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу. -сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен квадрату текущего индекса, увеличенному на 5; 2-й равен целой части квадратного корня из предыдущего элемента; 3-й равен целой части от деления двух предыдущих элементов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Immortal3331
Marina281
avguchenkov
Панков1101
irinakuznetsova994741
om805633748
TOKAREVA Stepan
didizain
Goldaram84
mariy-inkina8
yastrik
Aleksandr362
Ubuleeva826
gbfedak220
Юлия Соколовская1568