irina-mic
?>

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. (через паскаль)

Информатика

Ответы

es196

не особо. его произведения конечно игрались в салонах, но большую популярность он обрёл после своей смерти

ОвчинниковаТатьяна

паскаль.

 

 

program jjj;

var a: array [1..10] of integer; i,summa,proizv: integer;

begin

for i: =1 to 10 do begin

    writeln('напишите элемент массива номер ',i); read(a[i]);

                        end;

for i: =1 to 10 do begin

                              if a[i] mod 2=0 then summa: =summa+a[i] else

                                if (a[i]< =10) and (a[i]> =1) then   proizv: =proizv*a[i];

                          end;

writeln(summa,'   ',proizv); readln;

end.

 

жирным - это то, что я добавил)

Ubuleeva826
Console.writeline("введите название кинотеатра "); string kino = convert.tostring(console.; console.writeline("введите название фильма "); string film = convert.tostring("console.; console.writeline("введите время сеанса "); string time = convert.tostring(console.; console.writeline("введите стоимость билета "); int cena = convert.toint32(console.; console.writeline("приглашаем в наш кинотеатр  «" + kino + "». у нас вы можете посмотреть фильм  «" + film + " » в " +  time + ". цена билета " + cena + "р."); если и в дальнейшем будет нужна с c#, то пиши в сообщения, контакты.
Inforealto
Yaaas, я дождался c#, надеюсь что еще нужно console.writeline("введите первое число: "); int a = convert.toint32(console.; //первое число, , кэп console.writeline("введите второе число: "); int b = convert.toint32(console.; // второе числоconsole.writeline("введите третье число: "); int c = convert.toint32(console.; // третье числоconsole.writeline("введите четвертое число: "); int d = convert.toint32(console.; // четвертое число int [] mass = new int {a, b, c, d}; // заносим числа в массив for (int i = 0; i < mass.length; i++) //пробегаем по массиву {       int module = math.abs(mass[i]); // находим модуль       int koren = math.sqrt(mass[i]); // находим корень       int stepen = math.pow(mass[i], 4); // находим 4 степень       console.writeline( math.round(mass[i], 2) +  " " + math.roubnd(module, 2) +  " " + math.round(koren, 2) +  " "  + math.round(stepen, 2) + "\n"); // выводим таблицу. \n - перенос на следующую строку } если что, то не проверял запускается она или нет, лень vs включать. но по идее все так должно быть. если что - пиши. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. (через паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gaina6678
zotovinbox468
dkedrin74038
nelli-bi6
Anatolevich_Kulikov1229
Aleks0091
Иванникова736
innaglobal21
mantseva
amarantmetall
ariyskayaa5
moisalexx7
purbuevat56524
evamining
Richbro7