?>
Паскаль 1) составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем. 2) составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1 число n, первый элемент и разность прогрессии вводятся пользователем. вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.
Ответы
1)
var a: 1000..9999;
a1, a2, a3, a4: 1..9; //цифры числа
begin
writeln('введите четырехзначное число');
readln(a);
a4: = a mod 10; //последняя цифра
a3: = (a mod 100) div 10;
a2: = (a mod 1000) div 100;
a1: =a div 1000; //первая слева цифра
writeln('произведение цифр числа: ',a1 * a2 * a3 * a4);
end.
2)
var
n: integer;
d, s: real;
a1: real;
begin
writeln('введите число n');
readln(n);
writeln('введите разность прогрессии');
readln(d);
writeln('введите первый элемент');
readln(a1);
s: = ((2*a1+d*(n-1))/2)*n;
writeln('номер: ', n-1, ' значение: ', a1+d*(n-2));
writeln('номер: ', n, ' значение: ', a1+d*(n-1));
writeln('номер: ', n+1, ' значение: ', a1+d*n);
writeln('сумма ', n, ' первых элементов равна: ',s);
end.