DJXEz80
?>

1. составьте программу , которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, возводя в квадрат все элементы с чётными индексами.

Информатика

Ответы

Svetlana ALLA
Var  n,i: integer;   a: array[1..100]of integer; begin   //read(n);     n: =10;     randomize;     for i: =1 to n do        a[i]: =random(11);     for i: =1 to n do        write(a[i],' ');   writeln;   writeln('');     for i: =1 to n do    if(i mod 2 =0)then write(sqr(a[i]),' ');       readln; readln; end.
ЕленаГерасимова

1)

var a: array [1..100] of integer; объявляем массив

i,n: byte; объявляем переменную i и переменную   n   для хранения количества элементов

 

begin

write('введите n = '); readln(n); вводим n

for i: =1 to n do begin от 1 до n   цикл 

write('a[',i,']=');

readln(a[i]); вводим элементы в массив

end;

write('исходный массив:   ');

for i: =1 to n do выводим наш массив полностью

write(a[i],' ');

writeln;

write('результат:   '); выводим результат, в данном случае все элементы стоящие на четных местах

for i: =1 to n do

if i mod 2 =0 then write(a[i],' '); проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент

end.

 

2)

var a: array [1..100] of integer;

i,n: byte; s: longint; s объявляем для хранения суммы элементов

 

begin

s: =0; обнуляем s

write('введите n = '); readln(n);   тут тоже самое, что и в первой

for i: =1 to n do begin

write('a[',i,']=');

readln(a[i]);

s: =s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s

end;

write('исходный массив:   ');

for i: =1 to n do   вывод массива

write(a[i],' ');

writeln('сумма всех элементов массива = ',s); вывод суммы

end.

 

удачи=)

lelikrom2202

компьютерные технологии сегодня широко используются во всех областях человеческой деятельности. знание предмета и основ информатики имеет большое значение в наши дни. изучить информатику, в принципе, сможет любой желающий. просто у кого-то это займёт меньше времени и сил, а у кого-то больше.

поставьте для себя конкретные цели, которых вы хотите достичь, изучая информатику. прежде всего, сделайте акцент на основные понятия и процессы. когда вы оссвоите азы, обучение не будет требовать больших усилий. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составьте программу , которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, возводя в квадрат все элементы с чётными индексами.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

evrotrastop64
ella-rudenko
nickcook424
naromanova
Eduard Melikyan
Aleksandrovna Kolesnik1764
s2010av565
Merkuloff78
Kharkina1328
merzlikinairena
Chistov9721209
alexluu33
mishapavlov9
muraveiynik
barg562