. bmp – растровый рисунок, созданный в Paint
. jpg . gif – более совершенные растровые граф.
форматы. Рис. в формате gif может быть
анимированным и прозрачным)
. cdr – векторный файл
.mpg3 – звуковой файл
.mpg 4, wma, awi – видео файл
.rar, .zip- Архивные файлы
По расширению Windows определяет картинку(пиктограмму) для отображения файла и программу
для его открытия. Поэтому расширение нельзя стирать или изменять.
Существует много различных значков для отображения файлов и папок. Каждому типу файлов на
компьютере соответствует 1 значок, что позволяет легко узнать тип файла. Традиционные значки
можно изменять, но лучше этого не делать – это затруднит поиск информации на компьютере. Также
следует помнить что «традиционные» значки немного изменяются в каждой следующей версии
операционной системы.
Объяснение:
var n,i: integer; // объевляем переменные типа integer
function fact(n: integer): integer; // создаем функцию для нахождения факториала - которая принимает число (integer) и возвращает integer
begin // начало функции
if n = 1 then // проверка на то что число равно 1
fact:= 1 // если n=1, то факториал 1
else // если n не 1
fact:=fact(n-1)*n; // то ищем факториал
end; // конец функции
begin // старт программы
for i:= 1 to 9 do // цикл от 1 до 9
if i mod 2 = 1 then // проверка числа на остаток
writeln(fact(i)); // пишем факториал
end. // конец программы
Поделитесь своими знаниями, ответьте на вопрос:
Плис. на паскале.написать программу которая соединяет две строки, введенные с клавиатуры.