Boldinova-Marianna
?>

Напишите программу, которая заполняет массив из 20 элементов числами на отрезке [50; 150] и находит в нём минимальный из чётных элементов и его номер​

Информатика

Ответы

fetisov68av

const n=27;

var a: array [1..n] of integer;

i: integer;

begin

write('       исходный массив: ');

for i: =1 to n do

begin

a[i]: =random(26)-10;

write(a[i]: 3,' ');

if a[i] mod 2 < > 0 then a[i]: =3

else a[i]: =a[i]-3//уменьшает на 3,т.к. при уменьшении в 3 раза получается тип real, тут или второй массив создавать или взять a[i]: =a[i] div 3 (целочисленное деление)

end;

writeln;

write('преобразованый массив: ');

for i: =1 to n do write(a[i]: 3,' ')

end.

veraplucnika

program minpomeniatispervam;

type massiv=array[1..50]of integer;

var v: massiv;

    n,i, minim, indmin, temp: integer;

begin

  write('n='); read(n);

  writeln(' vvedi ',n,' cisel: ');

  read(v[1]); minim: =v[1]; indmin: =1;

  for i: =2 to n do

    begin

      read(v[i]);

      if v[i]< minim   then begin minim: =v[i]; indmin: =i; end;

    end;

  temp: =v[1]; v[1]: =v[indmin]; v[indmin]: =temp;

  writeln('new massiv: ');

  for i: =1 to n do

    write(v[i],'   ');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая заполняет массив из 20 элементов числами на отрезке [50; 150] и находит в нём минимальный из чётных элементов и его номер​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Бирюков Карпова1379
Анастасия Елена
Мелконян1137
sssashago8
jim2k
elenaowchinik4842
innavinogradova1385
margarita25061961
tokarevaiv
dentinnsmr467
lazaren-ko
sebastianpereira994
myrisik2490
sve-lysenko
Алексей Шуклин