lazaren-ko
?>

Напишите программу на паскале: условие составить алгоритм вывода стоимости товаров в чеке до первой суммы, превышающей 1000 рублей.

Информатика

Ответы

Aleksandr-Andrei
Program Z_1;
uses crt;
var a,b,c,s: integer; {a,b,c- товары(если нужна стоимость с копейками поменяй integer на real, добавь переменные, если нужны еще товары), s-чек}
begin
while d<=1000 do begin
writeln('Введите стоимость товаров'); readln(a,b,c); {задается стоимость товаров с клавиатуры}
d:=a+b+c;
end;
writeln(d);
end.
kengyra
Объем звукового файла равен произведению характеристик.
32000 гц * 4 байт * 120 секунд * 4 канала = 1000 * 2^5 * 2^2 * 120 * 2^2 = 120000 * 2^9 = 60000 * 2 * 2^9 = 60000 * 2^10 байт

Чтобы перевести в мегабайты, нужно два раза разделить на 1024

(60000 * 2^10)/(1024*1024) = 60000/1024

Так как нужно примерное время, можем 1024 принять за 1000, то есть получается ~60 Мб.

2. Комбинаторика. Слова состоят из пяти букв, буква Х может быть либо на последнем месте, либо её нет вообще

Х

Каждая оставшаяся звездочка принимает одно из оставшихся трёх значений. Для первого случая количество слов будет равно 3^4 = 81, для второго 3^5 = 243. Общее количество слов равно
81+243 = 324
info7
Число всевозможных размещений n символов по k позициям находится, как n^k
Рассмотрим первый вариант, когда символ Х стоит на последнем месте:
Всего 5 позиций. Последняя из них точно будет занята символом Х, тогда свободными остаются первые 4 позиции: * * * * Х
На каждую из них может приходиться какой-то один из символов А, В или С
Тогда общее число возможных вариантов вычисляется, как 3^4 = 81.

Рассмотрим второй вариант, когда символа Х нет вовсе. В этом случае на каждую из 5-ти позиции может приходиться один из символов А, В или С.
Тогда общее число вариантов вычисляется, как 3^5 = 243 

В итоге получаем, что всего кодовых слов может быть 243+81 = 324.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале: условие составить алгоритм вывода стоимости товаров в чеке до первой суммы, превышающей 1000 рублей.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Lianchikavon
Veselova
ludmila-malev280
Postnikova-StreltsovaKyulbyakova
drevile57
Aleksei
dimanov
НиколаевнаОльга
rusinfopro
avdeevau807
Маринова
versalmoda2971
Владимир1524
kisa-luba
dentob72