vladusha47713
?>

Арбуз диаметром д1 см стоит на рынке с1 руб за кг, а арбуз диаметром д2 см стоит с2 руб за кг.толщина корки арбуза т мм.составить программу, сообщающую, какой арбуз выгоднее купить.плотность мякоти и корки считать равными.

Информатика

Ответы

osirparts7854
Var     d1,d2,t,c1,c2,s1,s2: real; begin write('диаметр 1-го арбуза (см): '); readln(d1); write('цена за кг 1-го арбуза: '); readln(c1); write('диаметр 2-го арбуза  (см): '); readln(d2); write('цена за кг 2-го арбуза: '); readln(c2); write('толщина корки  (мм): '); readln(t); t: =t/10; s1: =c1*power(d1/2,3)/(power((d1/2-t),3)); //стоимость ед.мякоти 1 s2: =c2*power(d2/2,3)/(power((d2/2-t),3));   //стоимость ед.мякоти 2 if s1< s2 then writeln('покупаем первый')   else writeln('покупаем второй'); end.
mail66
(д1 - (с1+т1)) - (д2 - (с2 + > 0, то выгоднее купить первый арбуз если < 0, то выгоднее купить второй арбуз
imiryakubov
1. program  z_1; var i,s; intger;   a: array  [1..50] of integer; begin for i: =1 to 50 do begin readln(a[i]); s: =s+a[i]; end; writeln(s); end. 2. program  z_2; var  c1,c2,pp: integer; begin readln(c1); readln(c2); pp: =round((c1*c2)/2); //  двух чисел writeln(pp); end. 3. program z_3; var k,v,s: integer; begin readln(k); //стоимость книги readln(v); //внесено денег if k=v then writeln('! ') else if k< v then writeln('возьмите сдачу : ',v-k) else writeln('недостаточно средств : ',k-v); end.
timeev3160
106function f(x: integer): integer; var      l, m: integer; begin      l : = x - 12;       m : = x + 12;       while l < > m do              if l > m then                      l : = l - m              else                      m : = m - l;       f : = l; end; begin      var x : = 100;       var r : = 0;       repeat              x : = x + 1;               r : = f(x);       until r = 2;       writeln(x); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Арбуз диаметром д1 см стоит на рынке с1 руб за кг, а арбуз диаметром д2 см стоит с2 руб за кг.толщина корки арбуза т мм.составить программу, сообщающую, какой арбуз выгоднее купить.плотность мякоти и корки считать равными.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Khiryanov
Magnolia200872
orb-barmanager
forosrozhkov
varvv15
festjob
Tatianarogozina1306
kep92
igor-790
Вишняков997
artem
Lazar
olimp201325
Yarovitsin
Ekaterina1654