sindika
?>

Составить программу в qbasic условие: составить программу в qbasic условие: составьте программу нахождения произведения двух наибольших из трех введенных чисел.

Информатика

Ответы

kapi30
Input "a="; a min = a input "b="; b if b < min then min = b input "c="; c if c < min then min = c x = a * b * c / min print x
pk199888
Сумма 4-х степеней n-значного числа не превосходит n * 9^4 < 10000n. с другой стороны, n-значное число больше 10^(n-2). для того, чтобы одно было равно другому, должно выполниться 10^(n - 2) < 10000n, 10^n < n * 10^6. так может быть, только если n < 7, поэтому ищем числа среди 1..999999. код: function sum4deg(n: integer): integer; var   s: integer; begin   s : = 0;   repeat     s : = s + sqr(sqr(n mod 10));     n : = n div 10;   until n = 0;   sum4deg : = s; end; var   i: integer; begin   for i : = 1 to 999999 do     if i = sum4deg(i) then       writeln(i); end.
хаджимурод1172
Program prog; function search(n: integer): integer; var   input: array[1..4] of integer;   even: array[1..4] of integer;   atlestone: boolean; begin   input[1] : = n div 1000;   input[2] : = n mod 1000 div 100;   input[3] : = n mod 100 div 10;   input[4] : = n mod 10;   if (input[1] mod 2 = 0)       begin           even[1] : = input[1];           atlestone : = true;       end;   if (input[2] mod 2 = 0)       begin           even[2] : = input[2];           atlestone : = true;       end;   if (input[3] mod 2 = 0)       begin           even[3] : = input[3];           atlestone : = true;       end;       if (input[4] mod 2 = 0)       begin           even[4] : = input[4];           atlestone : = true;       end;   if atlestone = true then       search : = low(even)   else       search : = -1; end;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в qbasic условие: составить программу в qbasic условие: составьте программу нахождения произведения двух наибольших из трех введенных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

luxoutlet
Шавкат кызы
marychev55
kattarina71
firsova5911
Маргарита794
Любовь-Волков1205
argent
Марюк-Мубариз
Воздвиженская
Исмагилова_Саният
Shamsulo
astahova
sky-elena712558
Sokolova-Shcherbakov