Bondarev_Ayupova795
?>

Решить в паскале 1) составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6. 2) введено 3-значное число. вывести число в зеркальном отображении. 3)введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.

Информатика

Ответы

mbykovskiy
Program task1; var  a : integer; begin   randomize;   a: = 0;   while (a < > 5) and (a < > 6) do    a: = random(7);   writeln(a); end.program task2; var  digit, i : integer;   digitstr : string; begin  readln(digit);   str(digit,digitstr);   for i: = length(digitstr) downto 1 do    write(digitstr[i]); end.program task3; var  digit : integer;   newdigit, digitstr : string; begin  readln(digit);   str(digit,digitstr);   newdigit: = digitstr[3] + digitstr[4] + digitstr[1] + digitstr[2];   writeln(newdigit); end.
mzubenko6
Для 2-байтовой ячейки: 59 = 0000000000111011 -59= 1000000000111011 - прямой код       = 1111111111000100    - обратный код (инверсия)       = 1111111111000101   - дополнительный код (после прибавления единички) 30 =   0000000000011110 -30 = 1000000000011110   - прямой код       = 1111111111100001     - обратный код (инверсия)       = 1111111111100010     - дополнительный код (после прибавления единички) ********************************* расчеты смотри на фото
Yelizaveta1848
Внаихудшем случае, последнее новогоднее число - 11111111. #include < iostream> bool isnewyearnumber(int n); int sumdigits(int num); bool haszero(int n); int main() {   const int lastnewyearnumber = 11111111;   long long sum = 0;   for(int i = 0; i < = lastnewyearnumber; i++)       if ( isnewyearnumber(i) )           sum += i;   std: : cout < < "сумма всех новогодних чисел: " < < sum < < '\n';   return 0; } bool isnewyearnumber(int n) {   if ( ! ( haszero(n) ) & & sumdigits(n) == 8)       return true;   else       return false; } int sumdigits(int num) {   int sum = 0;   while ( num > 0 ) {       sum += num % 10;       num /= 10;   }   return sum; } bool haszero(int n) {   if (n < 0)       n = -1 * n;   if (n % 10 == 0)       return true;   else if (n / 10 > 0)         haszero(n / 10);   else       return false; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить в паскале 1) составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6. 2) введено 3-значное число. вывести число в зеркальном отображении. 3)введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

teashop
Belov
Fetyukov
gunel1988alieva
semenov-1970
Эвелина
Татьяна902
Кононова-БЕСКРОВНАЯ
mishanay301csfp
turovskaya69
Rinatum1978
vitaliy
pimenov5
socofilesrus4
aynaakzhigitova