Var a,b,c,d: real; begin write('введите коэффициенты a, b, c: '); readln(a,b,c); d: =(b*b-4*a*c); if d< 0 then writeln('вещественных корней нет'); if d=0 then writeln('один вещественный корень'); if d> 0 then writeln('два вещественных корня'); end.
Lenuschakova1982316
18.02.2022
Определим количество зрителей (мест): 35*40 = 1400 то есть нужно определить количество бит, которое требуется для кодирования 1400 номеров. для кодирования 1400 номеров требуется как минимум 11 бит. разберемся, почему так: с десяти бит мы можем закодировать максимум 1024 номера, т.к. 2^10 = 1024 (степень двойки - это количество бит). то есть десяти бит явно не достаточно для кодирования 1400 номеров. зато с одиннадцати бит мы можем закодировать 2^11=2048 номеров, и этого достаточно для кодирования 1400 номеров. один номер занимает 11 бит, объем 216 номеров равен: 216*11 = 2376 бит ответ: 2376 бит.
Olegovich Nikolaevna
18.02.2022
Var hh, mm, ss: integer; begin readln(hh, mm, ss); if (hh in [0..23]) and (mm in [0..59]) and (ss in [0..59]) then writeln('корректно') else writeln('не корректно'); end. либо можно так: var hh, mm, ss: integer; begin readln(hh, mm, ss); if (hh > = 0) and (hh < = 23) and (mm > = 0) and (mm < = 59) and (ss > = 0) and (ss < = 59) then writeln('корректно') else writeln('не корректно'); end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Даны вещественные числа a, b, c. выяснить, имеет ли уравнение ах2 + bx + c = 0 вещественные корни. написать программу!