avto3132
?>

Разработка приложений с циклическими алгоритмами одна штука некоторого товара стоит 20, 4 руб. составить программу для построения таблицы стоимости 2, 3, …, 20 штук этого товара. в программе visual studio c#

Информатика

Ответы

Shago
For (byte i = 1; i < = 20; i++)     console.writeline("{0,2} шт.     {1: #000.00} руб.", i, i * 20.4); console.readkey(false);
windless-el
1) var n,z: integer; begin z: =0; //z=: 0 знак присваивания выглядит вот так ": =" //n=: 100 - не нужно иницилизировать параметр цикла. for n: = 200 to 500 do begin //for n: =100 to 1000 do begin - цикл должен идти от 200 до 500, а не со 100 до 1000 if n mod 14 = 0 then //if (n div 14 =0) then - div - целая часть от деления, а mod - остаток. z: =z+1; //writeln(n); - выводить n не нужно совсем, а вот увеличить счетчик не помешает //z: =z+1; - а вот тут уже лишнее end; writeln(z); end. 2) -73, выполнится  15 - 8 + 1 =  8 раз
myataplatinumb348
Type   digits=array[0..9] of byte; procedure rd(n: integer; var ad: digits; var f: boolean); { заполняет массив количеством повторений цифр числа n   f=true, если хоть одна цифра повторяется } var   i,d: byte; begin   for i: =0 to 9 do ad[i]: =0;   f: =false;   while n> 0 do begin       d: =n mod 10;       ad[d]: =ad[d]+1;       if ad[d]> 1 then f: =true;       n: =n div 10       end; end; var   i,j,n,k: integer;   a: digits;   f: boolean;   begin   for i: =1 to 2 do begin       write('n = '); read(n);       n: =abs(n); { против ввода отрицательных }       rd(n,a,f);       if f then begin           write('встречаются больше одного раза цифры ');           for j: =0 to 9 do               if a[j]> 1 then write(j,' ');           writeln           end       else writeln('все цифры в числе уникальны')       end end. пример n = 153632 встречаются больше одного раза цифры 3 n = 1030041 встречаются больше одного раза цифры 0 1 var   s,sr: string;   c: char;   i,j,n,p: byte;       begin   for i: =1 to 2 do begin       write('введите строку: '); readln(s);       n: =length(s);       sr: ='';       for j: =1 to n do begin           c: =s[j];           if pos(c,copy(s,j+1,n-j))> 0 then sr: =sr+c+' ';           end;       if length(sr)> 0 then writeln('встречаются больше одного раза символы ',sr)       else writeln('все символы в строке уникальны')       end end. пример введите строку: информатика встречаются больше одного раза символы и а введите строку: проблема все символы в строке уникальны

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Разработка приложений с циклическими алгоритмами одна штука некоторого товара стоит 20, 4 руб. составить программу для построения таблицы стоимости 2, 3, …, 20 штук этого товара. в программе visual studio c#
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bogdanovaoksa
Olgera1
mmoskow3
cholga69
Evsevia-a
Nikolaevich
aifbon
mzubenko6
Golovinskii_Sirotkina1944
Yevgenevna
alex091177443
aeykin
BrezhnevaKoidula
Erikhovich
koeman