sashab82
?>

Составьте программу на языке pascal: дана площадь квадрата вычислить периметр квадрата, (​

Информатика

Ответы

testovich1012

var a,s,p: real;

begin

writeln('введите s квадарата: ');

readln(s);

a: =sqrt(s);

p: =a*4;

writeln('p = ',p);

end.

e-liza-k

1)

2101 в двоичной в форме  100000110101 

для него нужно 12 разрядов, а в 2-х байтовой ячейке их 16 поэто дописываем спереди   4 нуля.

ответ: 0000100000110101.

 

2)

для этого нужно записать число в двоичном виде и записать для него дополнительный код и потом перевести в 16-ю сисему счисления

  0000100000110101   пр.

обратный код это код в котором все 0 заменены на 1, а 1 на 0

  1111011111001010   обр.

чтобы получит дополнительный код нужно прибавить 1

  1111011111001011   доп.

теперь смотрим по 4 разряда и заменяем 1 символом в 16 системе счисления

в 16- системе счисления это f7cb

 

3)f840 =  63552;

   

 

 

 

Sergei-Gradus199

var  a: array[1..15] of integer;   i: integer; begin  randomize;   for i : = 1 to 15 do

  writeln('исходныйы массив: ');   begin    a[i] : = random(21) - 10;     write(a[i], ' ');     a[i] : = a[i] * a[i] * a[i];   end;   writeln;

  writeln;

writeln('нечетные элементы преобразованного массива')  i : = 1;   while i < = 15 do  begin    write(a[i], ' ');     i : = i + 2;   end;   readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке pascal: дана площадь квадрата вычислить периметр квадрата, (​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arturo95
windless-el
Chopper-hinter25
kireevatatiana
daskal83
bagrjashv41
natkul22
vadim1140
Kaccak8778
Джамал1009
Lapushkin1988
Хабарьева Андрей1056
Andrei
udalova-yelena
svetkinm158
▲