I, n: integer; n : = 5; t : = 1; for i: =2 to n do t = t * i; t : = 1; i : = 1; while i < = n do begin t : = t * i; i : = i + 1 end; t : = 1; i : = 1; repeat t : = t * i; i : = i + 1 until i > n;
ktripoleva294
26.01.2021
Алгоритм на условном языке. m: =0. "количество отрицателных" p: =0 "количество положительных" i: =1. пока i< > 0 повторять i: =прочитать число, введенное с клавиатуры. если i> 0 то p: =p+1. если i< 0 то m: =m+1. конец цикла пока. вывести на экран('процент положительных = ', p/(p+ вывести на экран('процент отрицательных = ', m/(p+ алгоритм будет верно работать, если введено хотя бы одно число, отличное от нуля. в противном случае возникнет ошибка деления на ноль. в нормальных программах подобные случаи отлавливаются и корректно обрабатываются.
julkamysh9
26.01.2021
Pascalabc.net 3.4.0, сборка 1670 от 23.05.2018 внимание! если программа не работает, обновите версию! begin var a: =arrrandom(20,-20,60); a.println; var x: =readinteger('какое число ищем? '); if a.contains(x) then writeln('такое число есть') else writeln('такого числа нет') end. примеры 42 23 59 0 20 23 41 26 47 8 23 42 20 35 31 53 -4 53 8 14 какое число ищем? 25 такого числа нет 15 1 44 40 55 3 31 -12 29 33 4 -13 -12 43 -14 51 44 -2 41 18 какое число ищем? -12 такое число есть
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Нужно! нужно написать программу для нахождения факториала числа n тремя способами ( с цикла с предусловием, цикла с постусловием и цикла с параметром)