yfetyukov2
?>

По паскалю! введите три числа a, b, с. определите количество положительных чисел в данном наборе

Информатика

Ответы

e-s-i-k
Var   a, b, c: real;   n: integer; begin   write('введите через пробел три числа: ');   readln(a, b, c);   if a > 0 then n : = 1 else n : = 0;   if b > 0 then n : = n + 1;   if c > 0 then n : = n + 1;   writeln('положительных чисел- ', n) end. тестовое решение: введите через пробел три числа: -3.54 2.16 4 положительных чисел- 2
borodin
// pascalabc.net 3.2, сборка 1382 от 06.02.2017 // внимание! если программа не работает, обновите версию! begin   var n: =readinteger('количество строк (столбцов) в массиве: ');   writeln('*** исходный массив [',n,',',n,'] ***');   var a: =matrrandom(n,n,-10,10);   a.println(4); writeln(5*a.colcount*'-');   var k,l: integer;   write('введите l,k: '); read(l,k);   var lim: =a[l-1,k-1];   var s: =a.rows.selectmany(x-> x).where(x-> x< lim).sum;   writeln('искомая сумма равна ',s) end. пример количество строк (столбцов) в массиве: 6 *** исходный массив [6,6] ***   -4  -8  -7  -3  -6  -4     2  -9    1    9  -6    6   -9  -2  -8  -3  -1  -4   -1  -9  -3  -7    3  -3     5    9  -6    8  -1 -10   -1  -1  -5  -8  -9    4 введите l,k: 2 3 искомая сумма равна -138
Popova-Erikhovich
// pascalabc.net 3.2, сборка 1382 от 06.02.2017 // внимание! если программа не работает, обновите версию! begin   var n: =readinteger('количество строк в массиве: ');   var m: =readinteger('количество столбцов в массиве: ');   writeln('*** исходный массив [',n,',',m,'] ***');   var a: =matrrandom(n,m,-99,99);   a.println(4); writeln(5*a.colcount*'-');   a.cols.select(x-> format('{0,4}',x.where(y-> y> 0).('');   println(' - положительных');   a.cols.select(x-> format('{0,4}',x.where(y-> y< 0).('');   println(' - отрицательных'); end. пример количество строк в массиве: 5 количество столбцов в массиве: 8 *** исходный массив [5,8] ***   32  83 -68 -33 -63  43    0  30   81  46 -52  56  49  10 -31    9   -41 -56 -80  70 -95  94 -53  56     0 -87 -24  23 -54  24 -84  -3   22  74  54 -98  42  94 -68  59     3    3    1    3    2    5    0    4 - положительных     1    2    4    2    3    0    4    1 - отрицательных

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По паскалю! введите три числа a, b, с. определите количество положительных чисел в данном наборе
Ваше имя (никнейм)*
Email*
Комментарий*
▲