Guskov
?>

Напишите программу на языке vbs, содержащую окно ввода с вопросом «сколько вам лет? », и вывода текстового сообщения «вы ребенок»; «вы подросток»; «вы в зрелом возрасте»; «вы пенсионер». диапазон возрастов выберите на свое усмотрение.

Информатика

Ответы

Альберт Луиза1595
Var   s,s1: string;   i,n,n1,k,p: integer; begin   write('введите строку: '); readln(s); n: =length(s);   write('введите подстроку: '); readln(s1); n1: =length(s1);   k: =0; i: =1;   while i< =n-n1+1 do begin       p: =pos(s1,s,i);       if p> 0 then begin inc(k); i: =p+n1 end       else i: =n; { для выхода }       end;   writeln(s1,' встречается в ',s,' ',k,' раз(а)') end.   пример введите строку: наша таня громко плачет: уронила в речку мячик введите подстроку: ро ро встречается в наша таня громко плачет: уронила в речку мячик 2 раз(а)
qelmar461
Второе поколение.         элементная база. значительно повышается надежность и производительность, снижаются габариты и потребляемая мощность. развитие средств ввода/вывода, внешней памяти. ряд прогрессивных архитектурных решений и дальнейшее развитие технологии программирования- режим разделения времени и режим мультипрограммирования (совмещение работы центрального процессора по обработке данных и каналов ввода/вывода, а также распараллеливания операций выборки команд и данных из памяти)         в рамках второго поколения четко стала проявляться дифференциация эвм на малые, средние и большие. существенно расширилась сфера применения эвм на решение - планово - , производственными процессами и др.         автоматизированные системы (асу) предприятиями, целыми отраслями и технологическими процессами (асутп). конец 50-х годов характеризуется появлением целого ряда проблемно-ориентированных языков программирования высокого уровня (яву): fortran, algol-60 и др. развитие по получило в создании библиотек стандартных программ на различных языках программирования и различного назначения, мониторов и диспетчеров для режимами работы эвм, планированием ее ресурсов, заложивших концепции операционных систем следующего поколения.    

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке vbs, содержащую окно ввода с вопросом «сколько вам лет? », и вывода текстового сообщения «вы ребенок»; «вы подросток»; «вы в зрелом возрасте»; «вы пенсионер». диапазон возрастов выберите на свое усмотрение.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zhamynchiev
zhmulyov-denis8
Носов Тоноян
N-odes-art-school410
Strelkov-Roman1263
ylia89
doorhan42n6868
Varagyan1728
kate281078
Nikolaevna1623
dmdlir
ivan-chay19
leobashkurov1089
ЮрьевичКарпова1564
Суханова1532