ebelskaia
?>

Напишите программу на паскале, в которой выдается количество двузначных чисел, не кратных 5

Информатика

Ответы

asnika1989
Var i,a: integer; begin a: =0; for i: =1 to 90   do if i mod 5< > 0 then   a: =a+1; writeln('количество чисел не кратных 5: ',a); end.
katar050419735
Uses crt; const n=11; type vec=array [1..n] of integer; var f: vec; i, col, el,rez: integer; flag: boolean; begin for i: =1 to n do     begin     f[i]: =10+random(90);               if (f[i] mod 2 < > 0) then col: =col+1;     end; flag: =false; for i: =1 to n do     if (f[i] mod 2 = 0) then         begin               flag: =true;               el: =f[i];               exit;         end; rez: =col*el; writeln(' rez = ', rez); readln; end.
Olga1509
// f# open system; [< entrypoint> ] let main argv =     let rec getnumberfromconsole _ =         printf "please enter a correct 4-digits number? \n"         let maybeint = console.readline();         let mutable value = 0;         if int32.tryparse(maybeint, & value) & & value > = 1000 & & value < = 9999             then value             else (getnumberfromconsole null)     let rec power = function         | (x, 0) -> 1         | (x, n) -> x * power (x, n-1)     let getdigit sourcenumber digit =           (sourcenumber / (power (10, % 10     let number = getnumberfromconsole null     let resultnumber = getdigit number 0 * 1000 + getdigit number 1 * 100 + getdigit number 2 * 10 + getdigit number 3     printf "%d" resultnumber     console.readkey true |> ignore     0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале, в которой выдается количество двузначных чисел, не кратных 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gdmaslo
nailya-abdulova25
aivia29
Эдуардович873
dmitrymakarov003
dmitrovlug8248
Геннадьевич-Тимофеева158
georgegradoff122
Хачатурович978
dyatchina63
and-syr
Смирнов_Андрей691
julya847
Дмитриевич Бирковская69
Черепаха в кумире шестиугольник
ekatef45