nchalov2
?>

Создать программу на языке си 8кл вводятся катеты прямоугольн. треугольника, найти гипотенузу

Информатика

Ответы

алексей_Цуканов
Ну и создавай! ну если я и это же тебе ничего не даст!
potapenkoon72

public class MyClass {

   public static void main(String args[]) {

     System.out.println("1, 2, 3 == " + howManyEqualNumbers(new int[]{1, 2, 3}));

     System.out.println("2, 2, 3 == " + howManyEqualNumbers(new int[]{2, 2, 3}));

     System.out.println("2, 2, 2 == " + howManyEqualNumbers(new int[]{2, 2, 2}));

   }

   

   public static int howManyEqualNumbers(int[] numbers) {

       int result = 0;

       

       for (int i = 0; i < numbers.length; i++) {

           if (i == 0) {

               continue;

           }

           

           if (i == 1 && numbers[i] == numbers[i - 1]) {

               result += 2;

               

               continue;

           }

           

           if (numbers[i] == numbers[i - 1]) {

               result += 1;

               

               continue;

           }

       }

       

       return result;

   }

}

P.S.

Не забывайте нажать " ", поставить оценку, и если ответ удовлетворил, то выберите его как "Лучший" :)


4) Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из
yuklimochkina3

public class MyClass {

   public static void main(String args[]) {

       System.out.println("4, 4, 5, 5 == " + isValidMove(4, 4, 5, 5));

       System.out.println("4, 4, 4, 7 == " + isValidMove(4, 4, 4, 7));

   }

   

   public static boolean isValidMove(int fromRow, int fromCol, int toRow, int toCol) {

       int i;

   

       // Попытка двинуться в то место где фигура уже стоит

       if (fromRow == toRow && fromCol == toCol)

           return false;

   

       // Collision detection

       if (fromRow == toRow) {

           // горизонтальное движение

           if (fromCol < toCol) {

               // вправо

               for (i = fromCol + 1; i <= toCol; ++i)

                   if (!isValidPosition(fromRow, i))

                       return false;

           } else {

               // влево

               for (i = fromCol - 1; i >= toCol; --i)

                   if (!isValidPosition(fromRow, i))

                       return false;

           }

       } else if (fromCol == toCol) {

           // вертикальное движение

           if (fromRow < toRow) {

               // движение вниз

               for (i = fromRow + 1; i <= toRow; ++i)

                   if (!isValidPosition(i, fromCol))

                       return false;

           } else {

               // движение вверх

               for (i = fromRow - 1; i >= toRow; --i)

                   if (!isValidPosition(i, fromCol))

                       return false;

           }

       } else {

           // не валидное движение

           return false;

       }

   

       return true;

   }

   

   public static boolean isValidPosition(int row, int col) {

       boolean result = false;

       if (row > 0 && row < 7) {

           result = true;

       }

       

       if (col > 0 && col < 7) {

           result = true;

       }

       

       return result;

   }

}

P.S.

Не забывайте нажать " ", поставить оценку, и если ответ удовлетворил, то выберите его как "Лучший" :)


5) Шахматная ладья ходит по горизонтали или вертикали. Даны две различные клетки шахматной доски, оп

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать программу на языке си 8кл вводятся катеты прямоугольн. треугольника, найти гипотенузу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

hellomaxim
tihonovrv477
langprint
Гаевая1290
makeeva-nataliya60
Борисовна_Кашутина
Veselova
gen218
sport2293032
Chistov9721209
Eduard Melikyan
ale-protasov
kryukovaem
Меладзе_Владимир1695
Devaunka40