ksv89
?>

Составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до n (n велено с клавиатуры)

Информатика

Ответы

Vladimirovna Viktorovna
Var n,i,s: integer; begin writeln('введите n'); read(n); for i: =5 to n do if i mod 4=0 then s: =s+i; write ('сумма натуральных чисел которые кратны 4 равно ',s); end.
tarhan1221
1) цикл от 2 включительно, до 20 включительно. 2) видим первое условие: i> =3 и i< =8 соответственно, когда циклическая переменная будет равна 3 (i=3) будет выполнено условие. а также при i=9 условие не будет выполняться. 3) видим второй блок условий. они подразумевают, что квадрат переменной не должен быть выше границы в 20 единиц. берем на заметку, что квадрат 5 равен 25, что является подходящим под условие и принудительно завершит цикл. 4) итак, при первом цикле переменная равна 2. ни одно из условий не выполниться. при i=3 выполниться первое условие и сумма увеличиться на остаток от деления i на 2, т.е. на 1. это условие будет выполняться до 5, позже цикл прервёт второе условие. значит необходимо посчитать остатки от деления i (3..5) на 2. ответ: 2
ella-rudenko
Определим как работает условия и циклы в программировании. условия бывают строгие и не строгие. строгие- это когда число либо больше, либо меньше, либо равно числу или не равно. не строгие - это когда число либо больше или равно, либо меньше или равно. циклы работают по принципу: пока что условие выполняется, делать цикл. в данном случае i=1 и условие i> 1 строгое. т.е. если бы i=2, то условие бы выполнилось. в данном случае i=1 => i> 1 не выполняется и цикл не запуститься. ответ: 0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до n (n велено с клавиатуры)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shuttse
sotrudnik3
uksusoval617
veniaminsem
Viktoriya
artem-whitenoise142
knigi21212
denis302007
Olegmgu11986
sergeystepanov231
Yelizaveta1848
koam20167459
adminkuncevo
aifbon
tatarinova-51
▲