A2017
?>

Спаскалем дано натуральное число n. составьте программу, которая определяет, сколько цифр содержится в числе n.

Информатика

Ответы

detymira
Program acab; var n: real; i: integer; begin read(n); i: =0; repeat n: =n/10; i: =i+1; until abs(n)< 1; writeln(i); end.
Anatolevna
Основные сочетания клавиш ctrl+c: копирование ctrl+x: вырезание ctrl+v: вставка ctrl+z: отмена действия delete: удаление shift+delete: удаление выбранного объекта без возможности восстановления, не помещая объект в корзину ctrl с перетаскиванием объекта: копирование выделенного объекта ctrl+shift с перетаскиванием объекта: создание ярлыка для выбранного объекта клавиша f2: переименование выбранного объекта ctrl+стрелка вправо: перемещение точки ввода в начало следующего слова ctrl+стрелка влево: перемещение точки ввода в начало предыдущего слова ctrl+стрелка вниз: перемещение точки ввода в начало следующего абзаца ctrl+стрелка вверх: перемещение точки ввода в начало предыдущего абзаца ctrl+shift + клавиши со стрелками: выделение блока текста shift + клавиши со стрелками: выбор нескольких объектов в окне или на рабочем столе, а также выделение текста в документе ctrl+a: выделение всего документа клавиша f3: поиск файла или папки alt+ввод: просмотр свойств выбранного объекта alt+f4: закрытие активного окна или завершение работы активной программы alt+ввод: просмотр свойств выбранного объекта alt+пробел: вызов контекстного меню активного окна ctrl+f4: закрытие активного документа в приложениях, в которых одновременно можно открыть несколько документов alt+табуляция: переход между открытыми объектами alt+esc: просмотр объектов в том порядке, в котором они были открыты клавиша f6: поочередный просмотр элементов интерфейса в окне или на рабочем столе клавиша f4: отображение панели адресов в папке «мой компьютер» или в обозревателе windows explorer shift+f10: вызов контекстного меню для выделенного элемента alt+пробел: вызов системного меню для активного окна ctrl+esc: вызов меню «пуск» alt+подчеркнутая буква в названии меню: вызов соответствующего меню подчеркнутая буква в имени команды открытого меню: выполнение соответствующей команды клавиша f10: активация строки меню в используемой программе стрелка вправо: вызов следующего меню справа или подменю стрелка влево: вызов следующего меню слева или закрытие подменю клавиша f5: обновление активного окна клавиша backspace: просмотр содержимого папки, расположенной выше на один уровень в каталоге «мой компьютер» или обозревателе windows explorer клавиша esc: отмена выполняемого shift при загрузке компакт-диска в привод для компакт-дисков: предотвращение автоматического воспроизведения компакт-диска ctrl+shift+esc: вызов диспетчера
kiravalter1998697
Сильно зависит от контекста. допустим, вы знали, что какая-то девочка должна была выйти, а вышла именно девочка в желтом. тогда, так как могла выйти любая из 8-ми, а вышла именно в желтом, сообщение содержит 3 бита информации. если же выйти могло любое кол-во девочек, а вышла именно одна, да еще и с желтым платьем, то сообщение содержит 8 бит информации. теперь поясню: тут вопрос "какое кол-во информации" равнозначен вопросу "сколько бит мне нужно, чтобы закодировать все комбинации". так, чтобы закодировать 8 цветов нужно всего 3 бита, чтобы закодировать группу девочек, нужно 8 бит (каждый бит соответствует девочке, бит is set означает, что она вышла, бит not set - что она не вышла)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Спаскалем дано натуральное число n. составьте программу, которая определяет, сколько цифр содержится в числе n.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

universal21vek116
Bni1504
pbttehnology
smakejkina
vetviptime
Lorik-lorik29
chernovol1985255
kengyra
borisov
kun1969
funny-furiya
buriginast5
russstep
kotofei147516
kolefe22171