Bogataya Vladimir318
?>

7. написать программу на pascal, которая обменивает первую и третью строку массива.

Информатика

Ответы

Шапкина1531
Const   m = 5;   n = 8; var   a: array[1..m, 1..n] of integer;   i, j, t: integer; begin   randomize;   writeln('исходный массив');   for i : = 1 to m do   begin       for j : = 1 to n do       begin           a[i, j] : = random(101) - 50;           write(a[i, j]: 4)       end;       writeln   end;   for j: =1 to n do begin t: =a[1,j]; a[1,j]: =a[3,j]; a[3,j]: =t end;   writeln('полученный массив');   for i : = 1 to m do   begin       for j : = 1 to n do write(a[i,j]: 4);       writeln   end end. тестовое решение: исходный массив   45  20 -15  33 -37  26 -30  -3   -27  43 -24    4 -14  18 -50    5   -28 -47  11  27  -8  42 -19 -39   16  43 -18    0 -32  25  11  22   27 -37 -44 -38 -50    7 -45 -30 полученный массив   -28 -47  11  27  -8  42 -19 -39   -27  43 -24    4 -14  18 -50    5   45  20 -15  33 -37  26 -30  -3   16  43 -18    0 -32  25  11  22   27 -37 -44 -38 -50    7 -45 -30
tvshi
#include < iostream>                                 #include < math.h> ;                               using namespace std;                               int main(int argc, char* argv[])                              {                                    setlocale(lc_all, "russian");           double x1,x2,y1,y2,distance;                                           cout < < "введите координату x1: ";                                       cin> > x1;                                                       cout < < "введите координату y1: ";                                       cin> > y1;                                       cout < < "введите координату x2: ";                                       cin> > x2;                                       cout < < "введите координату y2: ";                                       cin> > y2;                                                                       distance=sqrt(pow((x2-x1),2)+pow((y2-y1),2));           // формула для вычисления расстояния             cout< < "расстояние между двумя точками: "< < distance< < endl;               system("pause"); }
juliapierrat
Знаковая система - набор символов определенного типа. любая знаковая система строится на основании символов определенного типа. в одной знаковой системе одни и те же правила работы со всеми  символами. каждая знаковая система имеет конечный набор символов, который называют алфавитом. количество символов в одной знаковой системе называют мощностью знаковой системы. язык - это естественная знаковая система. имеет алфавит, который состоит из букв, буквы возможность формировать слова - основу языка. мощность алфавита - 33 буквы. правила чтения слов  применяются для всех букв. написание одних и тех же букв в разных словах одинаково. десятичная система счисления - формальная знаковая система. это знаковая система.  алфавит состоит из набора цифр: 0, 1, 2, 3, 4 и т.д. мощность алфавита - 10 цифр. правила сложения, вычитания, умножения, деления, возведения в степень и других действий используется для любых чисел, состоящих из цифр десятичной системы. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

7. написать программу на pascal, которая обменивает первую и третью строку массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

happygal5224
Глазкова633
igor51766771
ziyaevak
elyashatdinova
anusha33325
derkachn6429
udalova-yelena
dmdlir
Kulikov1065
guzelda19904850
mushatolga
sarycheva659
armsam76
itartdesignprof