Объяснение:
program treugolnik;
uses crt;
var
x1, y1, x2, y2, x3, y3, p:real;
function dlina(a1,b1, a2,b2:real):real;
begin
dlina:=sqrt(sqr(a1-a2)+sqr(b1-b2));
end;
begin
writeln('Введите координаты 1-ой вершины');
write('x='); readln(x1);
write('y='); readln(y1);
writeln('Введите координаты 2-ой вершины');
write('x='); readln(x2);
write('y='); readln(y2);
writeln('Введите координаты 3-ей вершины');
write('x='); readln(x3);
write('y='); readln(y3);
p:=dlina(x1,y1,x2,y2)+dlina(x1,y1,x3,y3)+dlina(x2,y2,x3,y3);
writeln('Периметр=',p);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. используйте процедуру. входные данные входная строка содержит единственное натуральное число – длину стороны квадрата n . выходные данные программа должна вывести заполненный квадрат размером n × n , состоящий из знаков '*'.
// Внимание! Если программа не работает, обновите версию!
procedure ЗачемТутПроцедура(n:integer);
begin
MatrFill(n,n,'*').Println(1)
end;
begin
ЗачемТутПроцедура(ReadInteger('n='))
end.