myudanova631
?>

Написать в паскале 111. мышонок джерри улепетывает к своей норке по прямой. успеет ли кот том догнать джерри, если джерри находится как раз на полпути между томом и норкой? 118. даны коэффициенты квадратного уравнения a, b, c. найти действительные корни этого уравнения. 122. можно ли прямоугольный пакет размерами a, b, c положить в чемодан размерами x, y, z? 123.составить программу вычисления значения функций: а)1 при x> = 0; y=0 при x< 0 б)x^2 при x> 0 y=-x при x< =0 в)1 при x> =1 y=0 при -11 y=0 при -1< =x< =1 x+1 при x< -1

Информатика

Ответы

olofinskayae
118. даны коэффициенты квадратного уравнения a,b,c. найти действительные корни этого уравнения. program kv_ur; var a,b,c,x1,x2,d: real; begin writeln ('для решения квадратного уравнения'); writeln ('введите коэффициент a'); readln (a); writeln ('введите коэффициент b'); readln (b); writeln ('введите коэффициент c'); readln (c); d: =sqr(b)-4*a*c; if d< 0 then writeln ('так как дискрименант ',d,'< 0 уравнение не имеет решений');         begin            if d=0 then                            begin                                    x1: =-b/(2*a);                                     writeln ('так как дискриминант равен 0 уравнение имеет один корень: ');                                     writeln(x1);                             end;                           if d> 0 then                            begin                                     x1: =(-b- sqrt(sqr(b)-4*a*c))/2*a;                                     x2: =(-b+ sqrt(sqr(b)-4*a*c))/2*a;                                     writeln ('так как дискриминант ',d,'> 0 уравнение имеет два корня: ');                                     writeln ('x1=', x1, ' и x2=', x2);                             end;   end; end.   122. можно ли прямоугольный пакет размерами a,b,c положить в чемодан размерами x,y,z?   program chemodan; var a,b,c,x,y,z: real; begin writeln ('введите размеры пакета');   writeln ('введите длину a'); readln (a); writeln ('введите ширину b'); readln (b); writeln ('введите высоту c'); readln (c); writeln ('введите размеры чемодана'); writeln ('введите длину х'); readln (x); writeln ('введите ширину y'); readln (y); writeln ('введите высоту z'); readln (z);   if (a< =x) and (b< =y) and (c< =z) then writeln ('пакет можно положить') else writeln ('пакет положить нельзя'); end.  
Присакарь520

отличия оперативной памяти от внешней.: внешная память энергонезависимая (после выключения компьютера данные из нее не удаляются) носители внешней памяти обеспечивают транспортировку данных в тех случаях, когда компьютеры не объединены в сети (локальные или ). данные помещаются во внешную память, когда данные не используются в оперативной памяти)в скорости выполнения команд ввода/вывода. внешная память не имеет прямой связи с микропроцессром. оперативная память озу более быстродействующая после выключения компьютера данные в ней не сохраняются. доступ к элепементам оперативной памяти обеспечивается по адресам.обычно озу выполняется на интегральных микросхемах. внешная память работает на принципе магнитной записи.

agusarevich283

дано:                                 решение

n=256                                  n=2 в степени i

k=30*70*5                        256=2 в степени 8 бит

найти v                            v=i*k

                                                      v=8*30*70*5=84000бит

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать в паскале 111. мышонок джерри улепетывает к своей норке по прямой. успеет ли кот том догнать джерри, если джерри находится как раз на полпути между томом и норкой? 118. даны коэффициенты квадратного уравнения a, b, c. найти действительные корни этого уравнения. 122. можно ли прямоугольный пакет размерами a, b, c положить в чемодан размерами x, y, z? 123.составить программу вычисления значения функций: а)1 при x> = 0; y=0 при x< 0 б)x^2 при x> 0 y=-x при x< =0 в)1 при x> =1 y=0 при -11 y=0 при -1< =x< =1 x+1 при x< -1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sergeymartyn56
satinvova
Immortal3331
Ivanskvortsov25
Кирилл-Анна1023
Pilotmi247074
gorodof4292
bas7572513
alesia1986
AndreevManaeva
Rakitin
filippovev1
ivnivas2008
fouettearoma
tershova