Даны 2 целых числа m и n. напишите программу которая выводит на экран частное от деления m на n, если они делятся нацело, а в противном случае сообщение m на n нацело не делится.
Var m,n:integer; begin write('m:='); readln(m); write('n:='); readln(n); if m mod n = 0 then writeln(m,'/',n,'=',m/n) else writeln('Не делится нацело'); end.
nevori
21.08.2020
// PascalABC.NET 3.0, сборка 1073 var a,b,c:integer; begin Write('Введи a,b,c: '); Read(a,b,c); if (a=b) or (a=c) or (b=c) then Writeln('Есть пара одинаковых') else Writeln('Все числа различные') end.
Тестовое решение: Введи a,b,c: 6 3 -12 Все числа различные
Введи a,b,c: 5 -4 5 Есть пара одинаковых
// PascalABC.NET 3.0, сборка 1073 var n:string; a,b:char; begin Write('Введи натуральное число n: '); Readln(n); Write('Введи подряд пару разыскиваемых цифр: '); Read(a,b); if Pos(a,n)>0 then Writeln('В числе есть цифра '+a) else Writeln('В числе цифры '+a+' нет'); if Pos(b,n)>0 then Writeln('В числе есть цифра '+b) else Writeln('В числе цифры '+b+' нет') end.
Тестовое решение: Введи натуральное число n: 3141592653589793 Введи подряд пару разыскиваемых цифр: 47 В числе есть цифра 4 В числе есть цифра 7
// PascalABC.NET 3.0, сборка 1073 var i,n:integer; fiba,fibb,fib:longint; begin Write('Введи натуральное число (1-46): '); Read(n); if n<3 then Writeln('Число Фибоначчи равно 1') else begin fiba:=1; fibb:=fiba; for i:=3 to n do begin fib:=fiba+fibb; fiba:=fibb; fibb:=fib end; Writeln('Число Фибоначчи равно ',fib) end end.
Тестовое решение: Введи натуральное число (1-46): 13 Число Фибоначчи равно 233
Donat-Evgeniya793
21.08.2020
Наука Науки бывают разные. Есть батаника астрономия и т. д. Каждая наука изучает что-то. Например батаника изучает растения. Я думаю что очень интересно изучать какую нибудь науку! Образование Мне кажется что образование нужно каждому. Каждый человек должен быть образованным. Для этого нужно ходить в школу. Закончить 9-11 классы и пойти на работу. Культура Тебе наверно известно слово культура. Мне кажется что все люди должны быть культурными. Но к сожалению не все люди могут быть культурными. С культурным человеком приятно общаться.
begin
write('m:=');
readln(m);
write('n:=');
readln(n);
if m mod n = 0 then
writeln(m,'/',n,'=',m/n)
else
writeln('Не делится нацело');
end.