Объяснение:
Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.
№1:
Для перевода целой части необходимо умножить разряд числа на соответствующую ему степень разряда.
101 = 2^{2}*1 + 2^{1}*0 + 2^{0}*1 = 4 + 0 + 1 = 5
Для перевода дробной части необходимо разделить разряд числа на соответствующую ему степень разряда
101 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 = 0.625
Аналогично:
№2
101 = 2^{2}*1 + 2^{1}*0 + 2^{0}*1 = 4 + 0 + 1 = 5
101000 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 + 2^{-4}*0 + 2^{-5}*0 + 2^{-6}*0 = 0.625
№3
11001 = 2^{4}*1 + 2^{3}*1 + 2^{2}*0 + 2^{1}*0 + 2^{0}*1 = 16 + 8 + 0 + 0 + 1 = 25
101000 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 + 2^{-4}*0 + 2^{-5}*0 + 2^{-6}*0 = 0.625
№4
10100 = 2^{4}*1 + 2^{3}*0 + 2^{2}*1 + 2^{1}*0 + 2^{0}*0 = 16 + 0 + 4 + 0 + 0 = 20
101 = 2^{-1}*1 + 2^{-2}*0 + 2^{-3}*1 = 0.625
Если не понятен значок ^{ } - это степень.
Вложение к следующему заданию
                  Поделитесь своими знаниями, ответьте на вопрос:
var count,k,m,R,L:longint;
begin
count:=0;writeln('Введите k'); readln(k);
for L:=1 to k do
begin
R:=0; m:=L;
while m>0 do
begin
R:=R*10+m mod 10;
m:=m div 10;
end;
if R=L then count:=count+1;
end;
writeln(count);
end.