spz03
?>

Составить программу, которая просит ввести любое число в интервале от 1 до 30, затем подсчитывает произведение чисел кратных 5 в интервале от 0 до введённого числа.

Информатика

Ответы

kiravalter1998697
Код Pascal1 2 3 4 5 6 7 8 const d=5; var n, i: integer; p: longint; begin   Write('Введите число от 1 до 30: '); ReadLn(n);   p:=1;   for i:=n div d downto 1 do p:=p*d*i;   WriteLn('Произведение кратных ',d,': ',p); end.
stachevay-lera
Using System;

public class Test
{
    public static int Main()
    {
        Random rnd=new Random(DateTime.Now.Millisecond); // иниц. датчика
        int n=Convert.ToInt32(Console.ReadLine());
        double[] Arr=new double[n];
        double e, max=0;
        for(int i=0;i<Arr.Length; i++)
        {
            Arr[i]=(int)(rnd.Next(1,99));
            Console.Write(Arr[i]+" ");
            e=Math.Abs(Arr[i]);
            if(e>max) max=e;
        }
        Console.WriteLine("\nmax={0:f1}",max);
        return 0;
    }
}

Пример
15
56 9 1 94 34 42 46 71 2 27 91 37 54 31 66
max=94.0
petrosyan35
Var 
s,s1,s2,st1,st2:string; i:integer; 
mn:set of char; b:boolean;
begin
writeln('Введите текст:');
readln(s);
s:=s+' ';
st1:=''; st2:='';
s1:=''; s2:=''; mn:=[]; b:=false;
while pos('  ',s)>0 do delete(s,pos('  ',s),1);
for i:=1 to length(s) do
 if s[i]<>' '
  then begin 
       s1:=s[i]+s1;
       s2:=s2+s[i];
       if s[i] in mn then b:=true;
       mn:=mn+[s[i]];
       end
  else begin
       if s1=s2 then st1:=st1+s1+' ';
       if not b then st2:=st2+s2+' ';
       s1:=''; s2:=''; mn:=[]; b:=false;
       end;
if st1<>''
 then writeln('Слова-перевёртыши: ',st1)
 else writeln('Слов-перевёртышей нет');
if st2<>''
 then writeln('Слова без повторяющихся букв: ',st2)
 else writeln('Слов без повторяющихся букв нет');
end.

Пример:
Введите текст:
заказ слово комок  пробел след пример огонь текст
Слова-перевёртыши: заказ комок 
Слова без повторяющихся букв: пробел след 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая просит ввести любое число в интервале от 1 до 30, затем подсчитывает произведение чисел кратных 5 в интервале от 0 до введённого числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sotrudnik3
genya1509
Андрееевич787
Valerevna
konss2
mnogomams47
Stanislavovna1237
Nazart44446
Ананян Иван1281
Tatgri
artem
olgolegovnak
many858
papanovar
albina6580