Составить блок схемы, написать программу для вычисления: 1) площади и периметра треугольника. 2) дан радиус окружности. найти длину и площадь окружности. огромное!
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017 // Внимание! Если программа не работает, обновите версию!
type Point=(real,real);
function ReadPoint(n:integer):Point; begin var a,b:real; Write('Координаты точки ',n,': '); Read(a,b); Result:=(a,b) end;
function GetPoints(n:integer):array of Point; begin Result:=new Point[n]; for var i:=0 to n-1 do Result[i]:=ReadPoint(i+1) end;
function Lsqr(a,b:Point):=sqr(b[0]-a[0])+sqr(b[1]-a[1]);
function Diags(a:array of Point; n:integer):array of real; begin Result:=new real[n*(n-3) div 2]; var k:=0; for var i:=0 to n-3 do for var j:=i+2 to min(n+i-2,n-1) do begin Result[k]:=Lsqr(a[i],a[j]); k+=1 end; end;
begin var n:=ReadInteger('Количество вершин:'); if n>3 then begin var a:=GetPoints(n); Writeln('Длина наибольшей диагонали равна ',sqrt(Diags(a,n).Max):0:5) end else Writeln('Диагонали отсутствуют') end.
Пример Количество вершин: 5 Координаты точки 1: -3 2.5 Координаты точки 2: 3 5.2 Координаты точки 3: 6.1 1 Координаты точки 4: 2 -7.3 Координаты точки 5: -5 -7 Длина наибольшей диагонали равна 14.58904
saa002
14.05.2021
Добрый день! И так, начнём.. *Вопрос: Изменится ли строка ST, над которой произведут операцию COPY? Почему? *ответ: Изменится, т.к. при использовании функции COPY необходимо указывать в какой строке копировать, с какой позиции, и количество символов, которое будет копировано. **Вопрос: Чему будет равняться k после операции k:=length(‘мышь и клавиатура’)? **ответ: Переменная k будет равна 17, т.к. функция LENGTH определяет длину строки, считая каждый пробел, запятую, буквы и т.д. ***Вопрос: Чему будет равняться переменная tx после операции tx:=‘лесник’; delete(tx,4,3)? ***ответ: Переменная tx будет равна слову лес. Функция DELETE удаляет часть символов из строки. В нашем случае удаление происходит в строке tx, с позиции 4, удаляет 3 символа. Вопрос: Чему будет равняться переменная k после операции tx:=‘баобаб’; k:=pos(‘ба’,tx)? ответ: Переменная k будет равна 1. Т.к. функция POS определяет первое вхождение заданного символа. Дополненная программа: program zadacha1; var t: string; b: string[1]; n, k, i: integer; begin writeln('Введите текст: '); readln(t); n := length(t); k := 0; for i := 1 to n do begin b := copy(t, i, 1); if (t[i] = 'a') or (t[i] = 'A') or (t[i] = 'а') or (t[i] = 'А') then k := k + 1; end; writeln ('k= ', k); end.
*Курсивом и выделением обозначены дополнения в программе.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить блок схемы, написать программу для вычисления: 1) площади и периметра треугольника. 2) дан радиус окружности. найти длину и площадь окружности. огромное!
r=R^2(радиус