aaltuxova16
?>

Составить программу сортировки в паскаль abc: даны три числа, расположить их в порядке убывания.

Информатика

Ответы

lazarevaavrora

program p;

vara,b,c,i,j,n : integer;

beginwriteln('введите три числа'); readln(a,b,c);

if a> b then if a> c then writeln(a,c,b) else writeln(c,a,b) else if c> b then writeln(a,b,c) else writeln(b,c,a);  

readln; end. 

allo22-27
// pascalabc.net 3.1, сборка 1230 от 27.04.2016 const   колстрок=3;   колстолбцов=5; begin   var массив: array [1..колстрок,1..колстолбцов] of integer;   var суммыпострокам: array[1..колстолбцов] of integer;   writeln('введите элементы массива (',колстрок,',',       колстолбцов,') построчно: ');   for var строка: =1 to колстрок do       for var столбец: =1 to колстолбцов do begin           read(массив[строка,столбец]);           суммыпострокам[строка]+=массив[строка,столбец]           end;   writeln('суммы построчно: ');   for var строка: =1 to колстрок do print(суммыпострокам[строка]) end. тестовое решение введите элементы массива (3,5) построчно: 7 -5 13 19 -11 8 23 -15 -6 0 12 -6 -9 0 12 суммы построчно: 23 10 9
Дмитрий_Пергамент669
Program lab5; const n=5; var p: array [1..n,1..n] of real; i, j : integer;   begin randomize; writeln('исходный массив p: '); for i: =1 to n do    begin   for j: =1 to n do   begin   p[i,j]: =10*random;   write(p[i,j]: 5: 1);   end;   writeln;   end; for i: =1 to n do    for j: =1 to n do   if j> i then p[i,j]: =0 else p[i,j]: =round(p[i,j]); writeln('изменённый массив p: '); for i: =1 to n do    begin   for j: =1 to n do write(p[i,j]: 5: 1);   writeln;   end; end. пример: исходный массив p:   6.0   6.5   4.2   0.6   4.6   5.7   8.8   0.3   6.2   9.0   3.0   5.3   4.0   6.0   4.8   6.0   3.0   5.0   5.3   8.7   8.9   8.8   6.8   5.3   5.1 изменённый массив p:   6.0   0.0   0.0   0.0   0.0   6.0   9.0   0.0   0.0   0.0   3.0   5.0   4.0   0.0   0.0   6.0   3.0   5.0   5.0   0.0   9.0   9.0   7.0   5.0   5.0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу сортировки в паскаль abc: даны три числа, расположить их в порядке убывания.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ЕленаАнастасия315
Alsergus7811
nataljatchetvertnova
mskatrinmadness
alina-bas
Monstr13
kononova_Pavel689
Marina658
stairov536
Mukhlaev-Olga
yuliyaminullina
goldenshtein33333
Остап-Лаврова1410
rigina82
anna241273
▲