Tatyanaaarzieva72
?>

Составить программу по информатике в pascal abc. 1. с клавиатуры одной строковой вводят имя и фамилию. составьте программу, которая: а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя ивыводит его; в) выводит сначала фамилию, а затем имя. 2. составьте программу, которая в строке "касіу ясь канюшыну" заменяет имя "ясь"

Информатика

Ответы

mashere59

1

a)

program pr;

var

s: string;

c: char;

i: integer;

begin

writeln('введите имя и фамилию в одной строке');

readln (s);

writeln('введите заданный символ');

readln (c);

for i: =1 to length(s) do if s[i]=c then writeln ('в строке найден заданный символ');

readln;

end.

б)

program pr;

var

s,n: string;

c: char;

i: integer;

begin

writeln('введите имя и фамилию в одной строке');

readln (s);

i: =1;

while s[i]< > ' ' do i: =i+1;

n: =copy(s,1,i-1);

writeln(n);

readln;

end.

в)

program pr;

var

s,n,f: string;

c: char;

i: integer;

begin

writeln('введите имя и фамилию в одной строке');

readln (s);

i: =1;

while s[i]< > ' ' do i: =i+1;

n: =copy(s,1,i-1);

f: =copy(s,i+1,length(s)-i+1);

writeln(n);

writeln(f);

readln;

end.

program pr;

var s: string;

begin

s: ='касіу ясь канюшыну';

delete (s,7,3);

insert ('слово которое хотите вставить',s,7);

writeln (s);

readln;

end.

 

svetlanam81
Использовать робот алг нач влево нц пока снизу свободно периметр мост кц кон алг мост нач вниз влево нц пока снизу не свободно если слева свободно то  влево все кц кон алг периметр нач закрасить вправо нц пока снизу не свободно закрасить вправо кц закрасить вниз нц пока слева не свободно и снизу свободно закрасить вниз кц закрасить влево нц пока сверху свободно закрасить вверх кц нц пока сверху не свободно закрасить влево кц закрасить вверх закрасить вправо нц пока снизу не свободно вправо кц вниз нц пока слева не свободно вниз кц кон
NatalyaAlekseevich1644
А) обычно используется для статистической обработки результатов эксперимента, когда по заданному набору точек на плоскости (хотя можно и не только для плоскости применять) получают функцию в виде уравнения (т. е. аналитически заданную) , непрерывную в области, заданной этими точками, которая максимально близко соответствует этому заданному набору точек. такое определение функции обычно называется табличным, а полученную в результате в аналитическом виде функцию - линией регрессии. критерий её поиска - минимизация суммы квадратов отклонений данной функции (линии регрессии) от изначально заданных точек, поэтому и называется "метод наименьших квадратов".б) основная  тенденция   изменения чего-либо: например, в —  временного ряда .в)  линия проходит через центр тяжести выборочных данных,  то есть выполняется равенство: y=b1+sum(bi·xi) г) нет, не может. потому что в этом случае параллельно опустив тренд до первой же точки , мы уже добьемся лучшего совпадения с экспериментальными данными. все расстояния от тренда до экспериментальных точек уменьшатся, а, значит, уменьшится и сумма квадратов расстояний.возможно,где-то я ошиблась

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу по информатике в pascal abc. 1. с клавиатуры одной строковой вводят имя и фамилию. составьте программу, которая: а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя ивыводит его; в) выводит сначала фамилию, а затем имя. 2. составьте программу, которая в строке "касіу ясь канюшыну" заменяет имя "ясь"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

potapenkoon72
Ваган Шутова332
Nastyakarysheva8750
mariia39
rashodnikoff
Kalugin Vyacheslavovna605
Magnolia200872
Половников1964
okabankova7
T91610933073266
stachevay-lera
Анатольевич-Лариса
Сопова
Igor1406
katrin819