Zladthesecond577
?>

Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет отрицательные на -1

Информатика

Ответы

Aleksei Aleksandrovna649
Var a:array[1..7] of integer; i:integer; n1:real;
begin
writeln('Введите 7 целых чисел');
for i:=1 to 7 do
begin
repeat
read(n1);
if (n1<>round(n1)) then  writeln('Необходимо целое число');
until (n1=round(n1));
a[i]:=round(n1);
end;
for i:=1 to 7 do
begin
if a[i]<0 then a[i]:=-1;
end;
writeln('Полученный массив:');
for i:=1 to 7 do
write(a[i]:5);
writeln('');
end.
viktoritut
1Компьютер это -многофункциональное электронное устройство для работы с информацией;
2.Манипулятор "мышь" - это устройство:ввода информации;
3. В процессе загрузки операционной системы происходит:Последовательная загрузка файлов операционной системы в оперативную память
4.Во время исполнения прикладная программа хранится:в оперативной памяти;
5.При отключении компьютера информация стирается:из оперативной памяти;
6 .Расширение файла, как правило, характеризует:тип информации, содержащейся в файле;
7Полный путь файлу: c:\\books\\raskaz.txt. Каково имя файла? raskaz.txt;

8.Операционная система это -программная среда, определяющая интерфейс пользователя;
9 .Программой архиватором называют:программу для уплотнения информационного объема (сжатия) файлов;
10.Сжатый файл отличается от исходного тем, что:он занимает меньше места11. Файловый вирус: запускаются при запуске компьютера;
12 .В случае появления запаха гари из компьютера необходимо: продолжать работать на компьютере альтернативный ответ- в школе дермовая проводка и из-за этого может загореться вся школа, ибо комьютера сделны из саммых дешевых китайских зачастей13 .Правая кнопка мыши позволяет  вызвать меню следующего вида
ниспадающее14.В процессе  дефрагментации диска каждый файл  записывается обязательно в последовательно расположенных секторах
15 . В целях сохранения информации жесткие магнитные диски следует оберегать от :Света
Ударов при установке
16.При быстром форматировании гибкого диска: там меняются адреса на диске
17.Драйвер- это Программа, обеспечивающая работу устройства компьютера
18. Системный диск необходим для Хранения важных файлов
19.Программы, с которых пользователь решает свои информационные задачи, не прибегая к программированию, называются:
Прикладными программами
molchanovaelena284
1Компьютер это -многофункциональное электронное устройство для работы с информацией;
2.Манипулятор "мышь" - это устройство:ввода информации;
3. В процессе загрузки операционной системы происходит:Последовательная загрузка файлов операционной системы в оперативную память
4.Во время исполнения прикладная программа хранится:в оперативной памяти;
5.При отключении компьютера информация стирается:из оперативной памяти;
6 .Расширение файла, как правило, характеризует:тип информации, содержащейся в файле;
7Полный путь файлу: c:\\books\\raskaz.txt. Каково имя файла? raskaz.txt;

8.Операционная система это -программная среда, определяющая интерфейс пользователя;
9 .Программой архиватором называют:программу для уплотнения информационного объема (сжатия) файлов;
10.Сжатый файл отличается от исходного тем, что:он занимает меньше места11. Файловый вирус: запускаются при запуске компьютера;
12 .В случае появления запаха гари из компьютера необходимо: продолжать работать на компьютере альтернативный ответ- в школе дермовая проводка и из-за этого может загореться вся школа, ибо комьютера сделны из саммых дешевых китайских зачастей13 .Правая кнопка мыши позволяет  вызвать меню следующего вида
ниспадающее14.В процессе  дефрагментации диска каждый файл  записывается обязательно в последовательно расположенных секторах
15 . В целях сохранения информации жесткие магнитные диски следует оберегать от :Света
Ударов при установке
16.При быстром форматировании гибкого диска: там меняются адреса на диске
17.Драйвер- это Программа, обеспечивающая работу устройства компьютера
18. Системный диск необходим для Хранения важных файлов
19.Программы, с которых пользователь решает свои информационные задачи, не прибегая к программированию, называются:
Прикладными программами

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет отрицательные на -1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

upmoskovskiy
Есартия52
leobashkurov1089
iralkap
fedoseevalyubov
Филиппович_Николаевич
alexeylipatov
xeniagolovitinskaya4546
belegaj98
myhauz
Aleksey19801
Лихачев Полина1978
rodsher7740
Natacha3636672
Pirogovskii695