Составить программу. вывести с клавиатуры целое число, и определить, есть ли в нем повторяющиеся цифры.программа должна вывести"да" или "нет". заранее .
Uses crt; var s:string; i:integer; l:boolean; m:set of char; begin clrscr; write('Введите число :'); readln(s); l:=false; for i:=1 to length(s) do begin if (m<>m-[s[i]]) then l:=true; m:=m+[s[i]]; end; if l then Writeln('Да') else Writeln('Нет'); end.
agaloan8
08.01.2022
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016 begin var n:=ReadInteger('n='); if n<0 then Writeln(n,'! не определено: n<0') else if n=0 then Writeln('0!=1') else begin var p:BigInteger:=1; for var i:=2 to n do p*=i; Writeln(n,'!=',p) end end.
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016 begin var a:array[1..20] of integer; Randomize; for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println; var b:=Range(2,20,2).Select(i->a[i]); Writeln('Элементы с четными индексами по возрастанию'); b.Sorted.Println; Writeln('Элементы с четными индексами по убыванию'); b.SortedDescending.Println; end.
Тестовое решение: -15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40 Элементы с четными индексами по возрастанию -40 -28 -12 -11 -3 9 12 16 33 46 Элементы с четными индексами по убыванию 46 33 16 12 9 -3 -11 -12 -28 -40
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу. вывести с клавиатуры целое число, и определить, есть ли в нем повторяющиеся цифры.программа должна вывести"да" или "нет". заранее .
var s:string;
i:integer;
l:boolean;
m:set of char;
begin clrscr;
write('Введите число :');
readln(s); l:=false;
for i:=1 to length(s) do begin
if (m<>m-[s[i]]) then l:=true;
m:=m+[s[i]];
end;
if l then Writeln('Да')
else Writeln('Нет');
end.