akarabut343
?>

Впаскале: вывести на экран массив а(10) состоящий из случайных двузначных чисел. удалить первый чётный элемент. ) нужно написать программу.

Информатика

Ответы

atamanov5

var a: array[1..10]of integer; i,k: integer; beginrandomize; for i: =1 to 10 do a[i]: =random(90)+10; for i: =1 to 10 do write(a[i],' '); writeln; for i: =1 to 10 doif a[i] mod 2=0 then begin k: =i; break; end;

for i: =1 to 10 do if i< > k then write(a[i],' '); end.

Valerevna
// pascalabc.net 3.0, сборка 1088 const   n=6; var   a: array[1..n] of integer;   i: integer; begin   randomize;   writeln('*** исходный массив ***');   for i: =1 to n do begin       a[i]: =random(1001);       write(a[i],' ');   end;   writeln;   writeln('*** результат ***');   write(a[1],' ');   for i: =2 to n-1 do begin       if odd(a[i]) then a[i]: =a[i]+a[n]       else a[i]: =a[i]+a[1];       write(a[i],' ');   end;   writeln(a[n]) end. тестовое решение: *** исходный массив *** 706 46 715 899 103 308 *** результат *** 706 752 1023 1207 411 308
kenni19868
// pascalabc.net 3.0, сборка 1088 const   n=30; var   a: array[1..n] of integer;   i,k: integer; begin   randomize;   writeln('*** исходный массив ***');   k: =0;   for i: =1 to n do begin       a[i]: =random(1001);       write(a[i],' ');       if (a[i] mod 3 = 0) and (a[i] mod 10 = 1) then inc(k)   end;   writeln;   writeln('количество найденных элементов равно ',k) end. тестовое решение: *** исходный массив *** 503 187 764 452 351 819 339 940 681 369 938 874 639 212 633 825 983 830 121 801 889 36 479 14 357 382 631 8 402 61 количество найденных элементов равно 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впаскале: вывести на экран массив а(10) состоящий из случайных двузначных чисел. удалить первый чётный элемент. ) нужно написать программу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olegovna Volkov
fudan
zaravshan20134
Анатольевич
I.B.Petrishchev
Anastasiamoscow80
sveta740450
natabodrikova
Иван1764
centrprof20
elizabetmaslova3
Хабарьева Андрей1056
Светлана константин
kun1969
premiumoft