admiral-kazan
?>

Написать программу, которая выводит таблицу значений функции y=|x|. диапазон изменений аргумента - от -4 до 4, шаг приращения аргумента - 0, 5. (это цикл for)

Информатика

Ответы

Кулагина_Владимир1179
Var i:real;
begin
  i:=-4;
  while i<=4 do begin
      writeln('|',i,'|=',abs(i));
      i:=i+0.5;
 end;
end.
КузменковаЖигулин
Задание 1
Информационный объем I = 44100 Гц * 5 * 60 с * 16 бит = 211680000 бит = 26460000 байт = 25839,84375 Кбайт = 25,23422241210938 Мбайт

Задание 2
I = 1,3 Мбайт t = 1 мин Частота дискретизации v = 1,3 * 1024 * 1024 * 8 бит / 60 с / 8 бит = 22719,147 Гц

Задание 3
I = 5.1 Мбайт, t = 2 минуты, v = 22050 Гц Разрядность аудиоадаптера i = 5.1 * 1024 * 1024 * 8 бит / (2 * 60) с / 22050 Гц = 16,1685 бит (округленно 16 бит)

Задание 4
I = 0.01 Гбайт, i = 16 бит, v = 44100 Гц Время t = 0,01 * 1024 * 1024 * 1024 * 8 бит / 16 бит / 44100 Гц = 121 с (округляем до 120 с)
Александрович Василий
var   s : string[50];
  i, j, k : word;  
 f : boolean;  
function isSpace(ch : char) : boolean;
begin   isSpace := false;  
if ch = ' ' then isSpace := true;
end;  
begin   f := false;  
   repeat     j := 0;
    writeln('введите строку, состоящую из 2 слов');
    readln(s);    
for i := 1 to length(s) do    
   if isSpace(s[i]) then  
    begin    
     inc(j);      
   k := i;       end;
     if j =1 then f := true;
    until f;    
write(copy(s, k + 1, length(s)), ' ', copy(s, 1, k - 1)); 
end.
недавно такую писала :)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая выводит таблицу значений функции y=|x|. диапазон изменений аргумента - от -4 до 4, шаг приращения аргумента - 0, 5. (это цикл for)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Larisa-0888716
mel9152480522
Where to Watch ufc 173 live?
smakejkina
Рузиев_Давиденко
ivanovmk1977
nadezhda81
tsigankova2018
slipu817838
tteplovoz3789
dashafox8739
llipskaya
maksimovskiy7657
lolydragon
olkay
dfyurst708