Zakharov Lilit
?>

Даны три точки а(х1, y1), b(x2, y2) и c(x3, y3 определить, будут ли они расположены на одной прямой. если да, то указать координаты точки попавшей внутрь отрезка. напишите программу в pascal, .

Информатика

Ответы

shmanm26
Известно уравнение прямой, проходящей через две точки A(x₁,y₁) и B(x₂,y₂). Если третья точка C(x₃,y₃) лежит на этой же прямой, то после подстановки её координат уравнение обращается в тождество
\displaystyle \frac{x-x_1}{x_2-x_1}= \frac{y-y_1}{y_2-y_1} \to \frac{x_3-x_1}{x_2-x_1} \equiv \frac{y_3-y_1}{y_2-y_1}
Следовательно, нужно проверить, выполняется ли это тождество для заданных координат.
В этом тождестве есть одна неприятная вещь: если y₂=y₁ и/или x₂=x₁, то в знаменателе получается ноль, чему компьютер уж точно не обрадуется. Поэтому такой случай надо рассмотреть отдельно, исходя из геометрического смысла.
Если же y₂≠y₁ и x₂≠x₁, можно привести тождество к более удобному виду:
\displaystyle \frac{x_3-x_1}{x_2-x_1} \equiv \frac{y_3-y_1}{y_2-y_1} \to (x_3-x_1)(y_2-y_1)\equiv (y_3-y_1)(x_2-x_1); \\ p_1=(x_3-x_1)(y_2-y_1), \ p_2=(y_3-y_1)(x_2-x_1), \ p_1\equiv p_2
Поскольку координаты могут быть и не целыми, а такие нецелые ("вещественные") числа представляются в компьютере с ограниченной точностью, тождество может оказаться ложным по причине такой неточности. Для обхода такого случая будем полагать, что два значения равны друг-другу, если их разность по модулю не превышает некоторой малой величины, т.е.:
|p_1-p_2|\leq \epsilon, \ \epsilon=10^{-8}

Вернемся к случаю y₂=y₁. В этом случае прямая параллельна оси Х, т.е. тогда условием принадлежности третьей точки данной прямой будет y₃=y₁ при любом х. То же можно сказать и про случай х₂=х₁, когда следует проверить, что х₃=х₁.

Если все три точки лежат на одной прямой, то у средней из них значение любой из координат должно находиться между значениями двух одноименных координат крайних точек.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
var
  x1,y1,x2,y2,x3,y3,p1,p2:real;
  on_line:boolean;
begin
  // Без проверки считаем, что у двух любых точек
  // не может быть одинаковых координат
  Write('Координаты точки А: '); Read(x1,y1);
  Write('Координаты точки B: '); Read(x2,y2);
  Write('Координаты точки C: '); Read(x3,y3);
  if x3=x1 then on_line:=(x2=x1);
  if (not on_line) then
    if y3=y1 then on_line:=(y2=y1);
  if not on_line then begin
    p1:=(x3-x1)/(x2-x1); p2:=(y3-y1)/(y2-y1);
    on_line:=(abs(p1-p2)<1e-8)
    end;
  if on_line then begin
    Writeln('Точки лежат на одной прямой');
    if (x2>x1) and (x2<x3) or (x2>x3) and (x2<x1)
    then Writeln('Точка B внутри')
    else
      if (x3>x1) and (x3<x2) or (x3>x2) and (x3<x1)
      then Writeln('Точка C внутри')
      else
        Writeln('Точка A внутри')
    end
  else
    Writeln('Точки не лежат на одной прямой')
end.

Тестовое решение:
Координаты точки А: 1 2.5
Координаты точки B: 3 3.5
Координаты точки C: -4 0
Точки лежат на одной прямой
Точка A внутри
Marina658

Если правильно понял - то вот:

Объяснение:

=СУММ(адрес_ячейки1; адрес_ячейки2)

Функция СУММ позволяет вычислить сумму двух или более чисел. В этой формуле вы также можете использовать ссылки на ячейки.

=СЧЁТ(адрес_ячейки1:адрес_ячейки2)

Данная формула подсчитывает количество ячеек с числами в одном ряду. Если вам необходимо узнать, сколько ячеек с числами находятся в диапазоне c A1 по A30, нужно использовать следующую формулу: =СЧЁТ(A1:A30).

=СЧЁТЗ(адрес_ячейки1:адрес_ячейки2)

С данной формулы можно подсчитать количество заполненных ячеек в одном ряду, то есть тех, в которых есть не только числа, но и другие знаки. Преимущество формулы – её можно использовать для работы с любым типом данных.

=ДЛСТР(адрес_ячейки)

Функция ДЛСТР подсчитывает количество знаков в ячейке. Однако, будьте внимательны – пробел также учитывается как знак.

=СЖПРОБЕЛЫ(адрес_ячейки)

Данная функция избавиться от пробелов, не включая при этом пробелы между словами. Эта опция может быть чрезвычайно полезной, особенно в тех ситуациях, когда вы вносите в таблицу данные из другого источника и при вставке появляются лишние пробелы.

Annabill1987

Объяснение:

1) Организуем ввод данных

3) Создадим функцию, которая вычисляет сумму чётных элементов

4) Создадим функцию, которая вычисляет сумму нечётных элементов

5) Выведем разность первой и второй функции

Пример реализации функций (для чётных, для нечётных аналогично)

1) Если А чётно, то начнём с неё, иначе с А+1 элемента

2) Если В чётно, то закончим им, иначе В-1

3) Количество элементов N - ((Верхняя граница - нижняя граница) целочисленно разделить на 2) + 1  

4) Прогрессия (Нижняя граница + Верхняя граница)*N/2

5) Присваиваем значение 4 функции

6) Аналогично организуем для нечётных элементов

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны три точки а(х1, y1), b(x2, y2) и c(x3, y3 определить, будут ли они расположены на одной прямой. если да, то указать координаты точки попавшей внутрь отрезка. напишите программу в pascal, .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vkorz594
lolydragon
gorsimonyan4
sev-94428
zorinka777
turaev-1098
ИП-Сысоев1628
aniramix
egorova90356684858370
omigunova39
Ivanovich-A.V
Marianna45
Gor Anatolevich
manager9
oskar-pn