imiryakubov
?>

Вдвумерном массиве хранится информация о зарплате 20 человек за каж- дый месяц года (первого человека — в первой строке, второго — во вто- рой и т. составить программу для расчета общей зарплаты, полученной за год любым человеком, информация о зарплате которого представлена в массиве.

Информатика

Ответы

agafonovalyudmila346
Паскаля нет под рукой, но я себе это представляю как-то так...
Вдвумерном массиве хранится информация о зарплате 20 человек за каж- дый месяц года (первого человек
bykotatyana
Var a:array[1..12,1..20] of real;
  i,j,n:integer;
  s:real;
begin
// Заполним массив случайными значениями для теста
for i:=1 to 12 do
  for j:=1 to 20 do
    a[i,j]:=random*20000;
    
writeln('Номер сотрудника ');
readln(n);
for i:=1 to 12 do
  s:=s+a[i,n];
writeln('Зарплата за год ',s);
end.
Bondarev_Ayupova795

using System;

internal class Program {

   private static void Main() {

       Console.WriteLine("Введите минимум для счетчика");

       var min = int.Parse(Console.ReadLine() ?? throw new ());

       Console.WriteLine("Введите максимум для счетчика");

       var max = int.Parse(Console.ReadLine() ?? throw new ());

       Console.WriteLine("Введите значение для счетчика");

       var v = int.Parse(Console.ReadLine() ?? throw new ());

       var counter = new Counter(max, min, v);

       Console.WriteLine("Введите + для увеличение и - для уменьшения, иное для выхода");

       do {

           var c = Console.ReadKey();

           if (c.KeyChar == '+') counter.Increase();

           else if (c.KeyChar == '-') counter.Decrease();

           else break;

           Console.WriteLine($" => {counter.Value}");

       } while (true);

       Console.ReadKey();

   }

}

public class Counter {

   public readonly int Maximum;

   public readonly int Minimum;

   public int Value { private set; get; }

   public Counter(int maximum, int minimum, int counter) {

       this.Maximum = maximum;

       this.Minimum = minimum;

       counter = Math.Min(this.Maximum, counter);

       counter = Math.Max(this.Minimum, counter);

       this.Value = counter;

   }

   private Counter() {

       this.Maximum = 10;

       this.Minimum = 0;

       this.Value = 5;

   }

   public void Increase() {

       var value = this.Value + 1;

       if (value > this.Maximum || value < this.Minimum)

           return;

       this.Value++;

   }

   public void Decrease() {

       var value = this.Value - 1;

       if (value > this.Maximum || value < this.Minimum)

           return;

       this.Value--;

   }

}

gavrilasmax05
Если не ошибаюсь ответ г Автоматическое форматирование — это средство Word для анализа частей документа и распознавания отдельных элементов, таких как основной текст, заголовки, маркированные списки и др. Word может применить соответствующие стили к различным элементам текста для создания отформатированного документа. (О стилях вы узнали в уроках 12 и 13). Вы можете принять или отвергнуть автоматически предложенный формат, частично или в целом, и позже внести необходимые изменения в документ. Кроме применения стилей, автоматическое форматирование удаляет лишние пробелы между абзацами, автоматически форматирует адреса Internet, ллектронной почты и сетевые адреса как гиперссылки, выделяет полужирным начертанием или подчеркиванием текст, ограниченный звездочками (*) или символами подчеркивания (_), заменяет два дефиса (--) одним тирс II Т. Д.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вдвумерном массиве хранится информация о зарплате 20 человек за каж- дый месяц года (первого человека — в первой строке, второго — во вто- рой и т. составить программу для расчета общей зарплаты, полученной за год любым человеком, информация о зарплате которого представлена в массиве.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

antrotip
васильевич
Герасимова107
polyakovaelena
ekaterinaorl1998
missbuhgalter2013
valerii-borisovich550
ayanrsadykov
izykova22
lpcck2212
alex-kuzora4411
Григорьевич915
Igor1406
oyudina
Александровна1742