delfinmos
?>

Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c. суммы только отрицательных и суммы только положительных чисел последовательности.

Информатика

Ответы

kirik197308

ввод нуля означает завершение ввода(он нигде не учитывается)

 

program test; var sum, x, counter, sumofnegative, sumofpositive: integer; average: real; begin    sum: =0;     average: =0;     counter: =0;     sumofpositive: =0;     sumofnegative: =0;     read(x);     while x < > 0 do    begin      sum: =sum+x;       average: =average+x;       counter: =counter+1;       if x > 0 then          sumofpositive: =sumofpositive+x    else      sumofnegative: =sumofnegative+x;     read(x); end;     average: =average/counter;

    writeln('sum = ', sum);     writeln('arithmetic average = ', average);     writeln('the sum of positive numbers = ', sumofpositive);     writeln('the sum of negative numbers = ', sumofnegative);     readln; end.

kapriz1999
{в данной последовательности к числу сначала 2 раза  прибавляется 3, после один раз вычитается 3. данная программа "ест" много памяти, но с ходу я ничего лучше не могу придумать} //pascal abc.net v3.0 сборка 1111 var   i,k: integer;   ar: array[1..2100] of integer; begin ar[1]: =3; ar[2]: =6; ar[3]: =9; ar[4]: =6; i: =4; while i< 2015 do   begin;   inc(i);   ar[i]: =ar[i-1]+3;   inc(i);   ar[i]: =ar[i-1]+3;   inc(i);   ar[i]: =ar[i-1]-3;   end; write(ar[2015]); end.ответ: 2019
Вадим
Using system; class program {       static void main()       {               for(var x=-2; x< =2; x++){                       for(var y=-2; y< =2; y++){                               ispointonaxis(x, y);                       }               }               console.readkey();       }       static void ispointonaxis(int x, int y){               console.writeline("point  = {0}; {1}", x, y);               if (x*y ! = 0){                       console.writeline("point not on axis");                       return;               }               if (x == 0){                       console.writeline("point is on axis ox");               }else if (y == 0){                       console.writeline("point is on axis oy");               }       } }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c. суммы только отрицательных и суммы только положительных чисел последовательности.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zerckaln
Kochinev7
len22
мария Кузив1393
Исмагилова_Саният
inj-anastasia8
faberlic0168
rodin4010
shakmeev
Nekrasova
artemyanovich8
Aleksandrovich-Mayatskikh
dimiff5
adrinalin991
rnimsk149