Ingakazakova
?>

Написать программу: на концерте было k зрителя. из них k1 человек купили билеты по c1 рублей, а остальные-по с2 рублей. сколько денег (sum) было выручено от продажи билетов? (к=894 чел., к1=396 чел., с1=150 рублей, с2=200 рублей) объясните принцип действия оператора sum, не был на уроке, а ничего дельного не нашел

Информатика

Ответы

Анатольевич447

тут и обяснять особо нечего. сначала вычесляем сколько было "остальных" зрителей, потом общую сумму от продажи k1 человекам,  потом общую сумму от продажи k2(остальным) человекам, то и то складываем и присваиваем переменной sum.

program test; var k, k1, k2, c1, c2, sum: integer; begin    k: =894;     k1: =396;     c1: =150;     c2: =200;     k2: =k-k1;     sum: =k1*c1 + k2*c2;     writeln('sum = ', sum, ' rub'); end.

info32

разберем предложение "чернила на 99% состоят из воды" по количеству символов в каждом слове: - "чернила" - 7 символов - " "(пробел) - 1 символ - "на" - 2 символа - " "(пробел) - 1 символ - "99%" - 3 символа - " "(пробел) - 1 символ - "состоят" - 7 символов - " "(пробел) - 1 символ - "из" - 2 символа - " "(пробел) - 1 символ - "воды" - 4 символа значит всего символов: 7 + 1 + 2 + 1 + 3 + 1 + 7 + 1 + 2 + 1 + 4 = 30 если каждый символ кодируется одним байтом, значит информационный объем предложения равен 30 байтам. ответ: 30 байт

Shikhova-Vitalii1290

using system;

using system.linq;

namespace task29760750

{

    internal class program

    {

        private static void main(string[] args)

        {

            var n = int.parse(console.in.;

            var array = console.in.readline()

                .split(' ')

                .select(int.parse)

                .toarray();

            var x = int.parse(console.in.;

            var indices = array

                .select((t, i) => t == x ? i : -1)

                .where(t => t > 0)

                .toarray();

            console.out.writeline(indices.any() ? string.join(" ", indices) : "-1");

        }

    }

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу: на концерте было k зрителя. из них k1 человек купили билеты по c1 рублей, а остальные-по с2 рублей. сколько денег (sum) было выручено от продажи билетов? (к=894 чел., к1=396 чел., с1=150 рублей, с2=200 рублей) объясните принцип действия оператора sum, не был на уроке, а ничего дельного не нашел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mail66
ЛАРИСА Насоновская231
ver2bit29
ckiras9
Тамара_Григорьевна897
syana80
Mikhail1369
Andrei_Mariya
delta88
maria
татьяна1245
mulyugina365
nikolai37
misie1974
elenarumack