olarina6510
?>

1)дан вектор {zi}, i=.составьте программу ввода значений и вычисления длины этого вектора по следующей формуле: l=корень квадратный z1 в кв.+z2 в кв.+ в кв. 2)даны значения массива {ai}, i= и переменной х. составьте программу вычисления многочлена 10-й степени по формуле герона: а10х в 10 степени+а9хв 10 степени++а1х+а0=+а9)х+а8)х++а1)х+а0.

Информатика

Ответы

ktatarinova

1)

const

   handsfree = false;

   nmax = 50;

   random_min = -50;

   random_max = 50;

var

   a: array[1..nmax] of real;

   i, n: integer;

   sum: real;

begin

   {ввод массива}

   n := nmax;

   if handsfree then begin

       for i := 1 to n do

       begin

           a[i] := random(random_max - random_min) + random_min;

           write(a[i], ' ');

       end

   end

   else begin

       for i := 1 to n do

           readln(a[i]);

   end;

   writeln();

   

   {подсчет суммы}

   sum := 0;

   for i := 1 to n do

       sum := sum + sqr(a[i]);

   writeln('L = ', sqrt(sum));

end.

2)

const

   handsfree = false;

   nmax = 10;

   random_min = -50;

   random_max = 50;

var

   a: array[0..nmax] of real;

   i, n: integer;

   sum, x: real;

begin

   {ввод массива}

   n := nmax;

   if handsfree then begin

       for i := 0 to n do

       begin

           a[i] := random(random_max - random_min) + random_min;

           write(a[i], ' ');

       end

   end

   else begin

       for i := 0 to n do

           readln(a[i]);

   end;

   writeln();

   

   {подсчет суммы}

   write('x = ');

   readln(x);

   

   sum := a[n];

   for i := n - 1 downto 0 do

       sum := sum * x + a[i];

   writeln('S = ', sqrt(sum));

end.

Artyom
ОК, всё это циклы.
1) Цикл for (цикл с счётчиком), при этом при каждом шаге цикла счётчик увеличивается на 1. Пример:
for a:=1 to 10 do //Цикл будет выполнен 10 раз
2) Цикл for (цикл с счётчиком), при этом при каждом шаге цикла счётчик уменьшается на 1. Пример:
for a:=10 to 1 do //Цикл будет выполнен 10 раз
3)Цикл с постусолвием. Если условие не выполняется, выполняется цикл. Его особенность заключается в том, что цикл выполнится хотя бы один раз вне зависимости от условия. Пример:
k:=0;
repeat
inc(k);
until k<9 //10 раз
4)Цикл с предусловием. Пока условие выполняется, выполняется и цикл.
Пример:
k:=0;
while k<>10 do
inc(k); //10 раз
annayarikova
{Данная программа переводит любое сочетание символов ASCII в систему счисления заданную пользователем.}

//Pascal ABC.NET v3.0 сборка 1111

var
 a,i,b,r,n,j,bug:integer;
 s,se,slo,slof:string;

procedure preob(var a,b,n:integer; var se:string);
 begin
  repeat
   b:=a mod n;
   a:=a div n;
   str(b,se);
   s+=se;
  until (a<=n-1);
 end;

beginreadln(slo);
readln(n);
for j:=1 to length(slo) do
begin;
a:=ord(slo[j]);
preob(a,b,n,se);
str(a,se);
s+=se;
for i:=1 to length(s) div 2 do
begin;
se:=s[i];
s[i]:=s[length(s)-i+1];
s[length(s)-i+1]:=se[1];
end;
write(s,'-');
slof:=slof+s;
delete(s,1,length(s));
end;
end.

Пример ввода:
Домашняя работа на завтра.
2
Пример вывода:
11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{Таким образом, фразу "Домашняя работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)дан вектор {zi}, i=.составьте программу ввода значений и вычисления длины этого вектора по следующей формуле: l=корень квадратный z1 в кв.+z2 в кв.+ в кв. 2)даны значения массива {ai}, i= и переменной х. составьте программу вычисления многочлена 10-й степени по формуле герона: а10х в 10 степени+а9хв 10 степени++а1х+а0=+а9)х+а8)х++а1)х+а0.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aniramix
elenabarskova7145
pk199888
MISAKOVNA49
TrofimovAnastasiya828
porotikova1004
ksenyabobrovich7214
diana-020
Ainura Pokhomova
aprilsamara2019
klimovala2
zapros
salahovta
Melsan19914239
proporcia46